Can not enable python

Mark Raasveldt m.raasveldt at cwi.nl
Sun Apr 10 22:00:26 CEST 2016


Hey Shmagi,

This seems to be a bug actually. It seems the "embedpy" option was removed from monetdbd by a branch merge at some point. Sorry about that. I've added the option back in now, if you redownload the sources it should work.

Also, as an additional note, you seem to be using mserver5 and monetdbd together, which you shouldn't do. "Mserver5" is the server process that you should connect to. All monetdbd does is start "mserver5" in the background. Your first attempt didn't work because you started mserver5 with embedded python correctly enabled, then started a second server with embedded python disabled and then connected to the second server. If you had connected to the first server you started it should have worked.

Mark

----- Original Message -----
From: "Shmagi Kavtaradze" <kavtaradze.s at gmail.com>
To: "users-list" <users-list at monetdb.org>
Sent: Sunday, April 10, 2016 9:02:27 PM
Subject: Can not enable python

I created function in python, but when tried to call, I receive :

Embedded Python has not been enabled. Start server with --set
embedded_py=true

I stopped farm. used mserver5  --set embedded_py=true and got in mserver5
console output:

# MonetDB/SQL module loaded
# MonetDB/Python module loaded

Then I started farm and still getting same error. Then I did this:

monetdb stop dbname
monetdb set embedpy=true dbname
monetdb start dbname

Still getting same. Any ideas what I am doing wrong?

_______________________________________________
users-list mailing list
users-list at monetdb.org
https://www.monetdb.org/mailman/listinfo/users-list


More information about the users-list mailing list