Problem with Mtest.py and monetdb command

Stefan Manegold Stefan.Manegold at cwi.nl
Thu Jul 11 21:04:39 CEST 2013


Hi,

Running Mtest.py is not expected to result in 0 errors.
Some tests are known to fail (see http://monetdb.cwi.nl/testweb/web/status.php for the latest status of the different branches.
Some test will fail on some platforms / systems due to unavailability of some (non-crucial) packages.

Mtest.py is mainly used for internal development.
If you're interested in the details, please inspect the generated website at the URL that Mtest.py mentions.

As for monetdb: are you sure you successfully started the monetdbd daemon before using monetdb?

Stefan

----- Original Message -----
> Hey,
> 
> I am new to MonetDB. I installed MonetDB yesterday. And I run
> Mtest.py. The
> results are as below:
> 
> *!ERROR:  Testing FAILED SIGNIFICANTLY (18 out of 1854 tests failed)*
> *
> *
> *   40 out of 1854 tests could not be executed*
> *    1 out of 1854 tests produced slightly different output*
> *        sql/test/BugTracker-2012/predicate_select.Bug-3090*
> *   17 out of 1854 tests produced SIGNIFICANTLY different output*
> *        monetdb5/optimizer/inlineFunction*
> *        monetdb5/optimizer/ifthencst*
> *        monetdb5/tests/BugTracker/kunion-and-nil.Bug-1667*
> *        sql/jdbc/tests/Test_PSsomeamount*
> *        sql/jdbc/tests/Test_PSlargebatchval*
> *        sql/jdbc/tests/Test_PSmanycon*
> *        sql/jdbc/tests/Test_PSmetadata*
> *        sql/jdbc/tests/Test_PSsqldata*
> *        sql/jdbc/tests/Test_Rsqldata*
> *        sql/jdbc/tests/BugConcurrent_sequences*
> *        sql/test/BugTracker-2010/incomplete-utf8-sequence.Bug-2575*
> *
> sql/test/BugTracker-2012/conditions_when_for_triggers_do_not_work.Bug-2073*
> *        sql/test/BugTracker-2012/create_function.Bug-3172*
> *        sql/test/BugTracker-2012/currenttime.Bug-2781*
> *        sql/test/BugTracker-2012/null_except_null.Bug-3040*
> *        sql/test/BugTracker-2012/day-of-month-localization.Bug-2962*
> *        sql/test/Triggers/recursive_triggers*
> *
> *
> *
> *
> * First, check the testing results in  /usr/local/mTests/index.html
>  !*
> *
> *
> * Then, fix the problems by:*
> *  - fixing sources and test scripts*
> *  - fixing stable output by hand*
> *  - approving test output by Mapprove.py (cf. Mapprove.py -?)*
> *
> *
> * After that, re-run Mtest.*
> 
> I hasn't change any source code yet. I am not sure whether I
> installed it
> correctly.
> 
> Also now I have no problem with command monetdbd, mserver5, mclient.
> However, I cannot use command with monetdb, the error information is
> always
> as below:
> 
> monetdb: cannot find a control socket, use -h and/or -p
> 
> I did a little bit research, to me it seems that it should
> automatically
> find a socket. Tell me if I am wrong. I also try to use the option -h
> -P,
> which doesn't work still. Do I actually install it correctly  I tried
> to
> uninstall and reinstall it,but it hasn't solve the problem at all.
> 
> Thanks very much!
> 
> _______________________________________________
> users-list mailing list
> users-list at monetdb.org
> http://mail.monetdb.org/mailman/listinfo/users-list
> 

-- 
| Stefan.Manegold at CWI.nl | DB Architectures   (DA) |
| www.CWI.nl/~manegold/  | Science Park 123 (L321) |
| +31 (0)20 592-4212     | 1098 XG Amsterdam  (NL) |




More information about the users-list mailing list