[MonetDB-users] Installation Problems

Ying Zhang Y.Zhang at cwi.nl
Mon Sep 22 16:51:13 CEST 2008


Hello Scott,

First of all, thanks for trying MonetDB.

On Mon, Sep 22, 2008 at 07:46:28AM -0500, Scott Stephens wrote:
> I've been attempting to install MonetDB by compiling the Aug. 2008
> superball.  My system is 64-bit linux, specifically the Ubuntu
> Intrepid Ibex alpha .  It appears that the installation is failing
> while compiling the JDBC driver, with the error message:
> 
> BUILD FAILED
> java.lang.UnsupportedClassVersionError: Bad version number in .class file
> 
> I'm using the Sun Java 1.5.0 JRE and JDK.  You can look at my full
> installation log here:
> http://docs.google.com/Doc?id=dhqbmd8x_6fqdnn7c3
> Can somebody help me out?  I'm hoping I've just made an easily
> corrected newbie mistake, but I'm out of things to try.

This looks like you have multiple versions of java/javac installed on
your system. 'ant' might be using a different java compiler than the one
'javac' in your path (but I unfortunately don't know how to find which
javac ant is using...).
Can you maybe search for all java versions you have, and
remove/disable all but one version?


Kind regards,

Jennie

> 
> Thanks,
> 
> Scott




> 
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
> Build the coolest Linux based applications with Moblin SDK & win great prizes
> Grand prize is a trip for two to an Open Source event anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> MonetDB-users mailing list
> MonetDB-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/monetdb-users




More information about the users-list mailing list