[MonetDB-users] merovingian locking up - port issue?

Ross Bates rbates at gmail.com
Sat Sep 20 23:45:48 CEST 2008


I'm having an issue with merovingian locking up. This is the typical
scenario.

- Start mero and my db with ./merovingian sobi

- Everything works great for anywhere between 50 & 100 queries, then mero
stops responding (I'm using python, jdbc & php)

- I can still connect to the db from the command line using ./mclient -d
sobi -lsql -p 50001

- both merovingian and mserver5 processes continue to run, but mero will end
up dying within 1-2 minutes by itself leaving the mserver5 process running

- even when mero dies, it appears that all the ports are still in use. This
is the result of netstat -a AFTER mero is dead:

tcp        0      0 *:50000                 *:*                     LISTEN
tcp        0      0 *:50001                 *:*                     LISTEN
tcp        0      0 mayfair.local:50000     mayfair.local:48973
ESTABLISHED
tcp        0      0 mayfair.local:48973     mayfair.local:50000
ESTABLISHED
udp        0      0 *:50000                 *:*

- when I try to restart mero  to reattach it to the database it fails with
this error:

      ./merovingian: binding to stream socket port 50000 failed: Address
already in use

- stopping the db doesn't work becase mero isn't running.

      ./monetdb stop sobi

      warning: MonetDB Database Server is not running
      stop: cannot perform: MonetDB Database Server (merovingian) is not
running


- the only thing left to do is kill the mserver5 process and restart both
mero and the db.

Unfortunately the merovingian.log file doesn't tell me anything.

Any other tips for helping troubleshoot this issue? The version is 5.7.0 and
was built from the Aug 23rd nightly.

Many Thanks,
Ross
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.monetdb.org/pipermail/users-list/attachments/20080920/f767d5d4/attachment.html>


More information about the users-list mailing list