[MonetDB-users] [ADT] bug report?

Stefan Manegold Stefan.Manegold at cwi.nl
Mon Sep 1 22:39:58 CEST 2008


On Mon, Sep 01, 2008 at 10:08:09PM +0200, Hendrike Peetz wrote:
> Ok, I assume I should have set compiler options to --disable-strict.

well, for us, it should also work with --enable-strict (default in CVS
version as that is meant for developers --- and as a reminder to us to
produce clean code ... ;-)) --- but for "users", --disable-strict (default
in tarballs) is indeed just fine.

> But now I can still not check, because it says:
>
> $ make check
> make  check-recursive
> Making check in src
> make  check-recursive
> Making check in common
> make  check-am
> make[5]: Nothing to be done for `check-am'.
> Making check in gdk
> make  check-am
> make[5]: Nothing to be done for `check-am'.
> Making check in testing
> make  check-am
> rm -f Mapprove.py
> ln -s Mtest.py Mapprove.py
> make[4]: Nothing to be done for `check-am'.
> Making check in conf
> make  check-am
> make[3]: Nothing to be done for `check-am'.

for which part did you call `make check`?
for "MonetDB" (Common) there are indeed not tests; neither for
(MonetDB/)"java"; only for clients, MonetDB4, MonetDB5, sql, geom,
pathfinder, template there are tests and `make check` should work --- be
aware though, that some tests are known to fail on some platforms ...

> Sorry for bothering you, but we were two people (who do know the basics 
> of working with unix) trying to get this running today and couldn't make 
> it work.

No problem --- in fact, `make check` is not "mendatory" for getting it to
work --- just `make && make install` (or use monetdb-install.sh) and then
try to run `Mserver` (MonetDB4) or `mserver5` (MonetDB5) as a very basic
"sanitycheck".

Stefan

> Hendrike
>
>
> Begin forwarded message:
>
>> From: Hendrike Peetz <hendrike at peetz-intelligence.com>
>> Date: September 1, 2008 9:27:37 PM GMT+02:00
>> To: Monet at cwi.nl
>> Subject: [ADT] bug report?
>>
>> Dear people in charge,
>>
>> I have been spending a lot of time today trying to install Monet on  
>> Leopard 10.5.4, 64 bit, core 2 duo.
>>
>> Before I did anything with the cvs, I tried to work with the Super  
>> tarball version. Compiling was not a problem but the tests were not  
>> installed and I was not too sure wether everything is working. I thus 
>> wanted to install it properly:
>>
>> I checked out the latest version (friday I assume) from the cvs.
>> bootstrap and configure worked fine, but I had problems with the  
>> compiling.
>>
>> I tried gcc4.1 (apple) and gcc4.2 (apple) (Yes, I recompiled my c- 
>> compiler!). Both of them returned the attached error.
>> I am not sure wether this is my mistake or some weird code, but as I  
>> was able to compile the tarball version I assume its something in the 
>> code.
>>
>> Best regards,
>>
>> Hendrike
>>
>>
>>
>>
>>
>>
>

-- 
| Dr. Stefan Manegold | mailto:Stefan.Manegold at cwi.nl |
| CWI,  P.O.Box 94079 | http://www.cwi.nl/~manegold/  |
| 1090 GB Amsterdam   | Tel.: +31 (20) 592-4212       |
| The Netherlands     | Fax : +31 (20) 592-4312       |




More information about the users-list mailing list