[MonetDB-users] On Java/JDBC compatibility

Sander Kruseman kruseman at xs4all.nl
Wed Oct 31 09:52:42 CET 2007


I thought this might be of interest to some of you.

New Java releases are normally upwards binary-compatible with prior 
releases with only few minor/niche exceptions.

This implies that one should normally be able to use recent JVM versions 
to run MonetDB's (JDBC) class/jar files, even if these were compiled 
with an older JDK version.

See: http://java.sun.com/j2se/1.5.0/compatibility.html
and: http://java.sun.com/javase/6/webnotes/compatibility.html#binary

Note that the opposite does not hold: class/jar files cannot be run with 
a JVM older than that from the JDK used to compile them. (Every newer 
JDK marks its generated class files with a different class file version 
number, which is checked by the JVM.)

I hope this helps.

Sander Kruseman




More information about the users-list mailing list