[MonetDB-users] install script (monetdb-install.sh)doesn't work for current branch

Fabian Groffen Fabian.Groffen at cwi.nl
Tue Dec 18 13:22:43 CET 2007


On 18-12-2007 13:15:04 +0100, Stefan.Manegold at cwi.nl wrote:
> > Yes, horror.
> >
> > I don't understand why this wasn't properly communicated...
> 
> For convenience and consistency, the names of all tar balls and the
> top-level directories in them have been "canonicalized" in by Sjoerd on
> 2007/12/03 (please mind the last line of his checkin message):
> 
> ===================================================================
> 2007/12/03 - sjoerd:
> 
> Changed the name of the generated tar balls (and the name of the
> top-level directory within them).

> The names are now equal to what nightly testing created, so that
> doesn't have to rename the tar balls anymore.

--> "are now equal to what nightly testing created"

> The files are still installed in the same place as before.
> Building RPMs still works.
> 
> The main change in the code is that we no longer use @PACKAGE@ since
> that is the longer tar ball name which we don't want in the
> installation directories we create.  Also, we can't use the defaults
> 
> when installing include files since they would also otherwise be
> installed in a directory with @PACKAGE@ in it.
> 
> Note, this will undoubtedly negatively affect the monetdb-install
> script, but I leave it to its owner to fix that.

I fixed it a few days ago.

Apparently the naming has changed once again.  In any case they were NOT
"equal to what nightly testing creatED" this morning, as my symlinks
obviously suddenly were pointing into void.

Thanks.




More information about the users-list mailing list