[MonetDB-users] MonetDB XQuery Module Crash

Wouter Alink w.alink at alumnus.utwente.nl
Tue Jul 11 21:39:35 CEST 2006


I'm glad I could help out. 

I have reported it as a bug, although I don't really know what exactly
causes the problem. I haven't found a way to reproduce the bug. If you can
reproduce it, please let us know.

Can you perhaps remember if you at any time after you installed MonetDB and
before the error appeared, bailed out (pressed Ctrl-C or something like
that: "killall Mserver", a power failure...) during the execution of a
query? and in particular during the 100 or 200 MB query?

Sorry for bothering you with more questions again, but the bug does not pop
up often, so any input is welcome. 

Greetings,
Wouter


-----Original Message-----
From: monetdb-users-bounces at lists.sourceforge.net
[mailto:monetdb-users-bounces at lists.sourceforge.net] On Behalf Of Michael
Schmidt
Sent: dinsdag 11 juli 2006 20:44
To: Wouter Alink
Cc: Monetdb-users at lists.sourceforge.net
Subject: Re: [MonetDB-users] MonetDB XQuery Module Crash


Hi all,

> I read the discussion, and I might have experienced the same kind of 
> problem before. I think there is some problem with the naming (when a 
> document is previously shredded with the same name as a 'cached' 
> document). At the time I experienced the problem I couldn't figure out 
> what the exact problem was, but removing the dbfarm worked for me:
> 
> So perhaps you could try to:
> - stop Mserver
> - completely remove the dbfarm-folder (defaultpath is
> "$PREFIX/var/MonetDB/dbfarm") (hopefully you don't have important XML
> documents stored in the database ;)
> - start Mserver
> - and then run the large query (without running any other queries first)?

Thank you very much, everything works fine now! Just removed all dbfarm
subdirectories and the error message disappeared. And no, there were no
important XML documents stored in the database, only some XMark generated
streams ;-)!

Nevertheless: I never shredded any document before encountering the problem
the first time. Before I /only/ used direct loading from the query. I just
tried shredding to solve the problem...

Hope this helps to locate the bug!

Cheers
Michael
_____________________________________________________________________
Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
http://smartsurfer.web.de/?mc=100071&distributionid=000000000071



-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job
easier Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
MonetDB-users mailing list
MonetDB-users at lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/monetdb-users





More information about the users-list mailing list