[MonetDB-users] MonetDB XQuery Module Crash

Michael Schmidt m.schmidt00 at web.de
Tue Jul 11 20:44:07 CEST 2006


Hi all,

> I read the discussion, and I might have experienced the same kind of problem
> before. I think there is some problem with the naming (when a document is
> previously shredded with the same name as a 'cached' document). At the time
> I experienced the problem I couldn't figure out what the exact problem was,
> but removing the dbfarm worked for me:
> 
> So perhaps you could try to: 
> - stop Mserver
> - completely remove the dbfarm-folder (defaultpath is
> "$PREFIX/var/MonetDB/dbfarm") (hopefully you don't have important XML
> documents stored in the database ;)
> - start Mserver
> - and then run the large query (without running any other queries first)?

Thank you very much, everything works fine now! Just removed all dbfarm subdirectories and the error message disappeared. And no, there were no important XML documents stored in the database, only some XMark generated streams ;-)!

Nevertheless: I never shredded any document before encountering the problem the first time. Before I /only/ used direct loading from the query. I just tried shredding to solve the problem...

Hope this helps to locate the bug!

Cheers
Michael
_____________________________________________________________________
Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
http://smartsurfer.web.de/?mc=100071&distributionid=000000000071





More information about the users-list mailing list