[MonetDB-users] Bug with average of decimals when an empty table is returned

Fabian Fabian.Groffen at cwi.nl
Tue May 24 15:33:02 CEST 2005


Hi,

thanks for your interest.

Could you report this as a bug on our SourceForge bug page under the 
SQL/Core category? 
http://sourceforge.net/tracker/?group_id=56967&atid=482468

Regards,
Fabian

Arjen van der Meijden wrote:
> Hi list,
> 
> I noticed a weird result from AVG when doing one of my queries; 
> -1.7976931348623158e+307
> 
> Appearantly it happens with this minimal testcase:
> monetdb-> create table emptyone (field decimal(3,1));
> Operation successful
> 
> monetdb-> select avg(field) from emptyone;
> +------------------------+
> | scale_down_avg_field   |
> +========================+
> | -1.7976931348623158E307 |
> +------------------------+
> 1 row
> 
> The result should afaik be NULL, not this value. With a decimal(3) it 
> works correctly by the way. The same behaviour is seen with numeric(3,1) 
> vs numeric(3).
> 
> Best regards,
> 
> Arjen
> 
> 
> -------------------------------------------------------
> This SF.Net email is sponsored by Oracle Space Sweepstakes
> Want to be the first software developer in space?
> Enter now for the Oracle Space Sweepstakes!
> http://ads.osdn.com/?ad_id=7412&alloc_id=16344&op=click
> _______________________________________________
> MonetDB-users mailing list
> MonetDB-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/monetdb-users




More information about the users-list mailing list