<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:verdana,helvetica,sans-serif;font-size:10pt"><div>In fact, then all of the sample programs, sample0.c--sample4.c and smack00.c--smack01,c pass NULL for the database field.<br></div><div style="font-family:verdana, helvetica, sans-serif;font-size:10pt"><br><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><font face="Tahoma" size="2"><hr size="1"><b><span style="font-weight: bold;">From:</span></b> Stephen P. Morgan <stephen_p_morgan@sbcglobal.net><br><b><span style="font-weight: bold;">To:</span></b> Communication channel for developers of the MonetDB suite. <developers-list@monetdb.org><br><b><span style="font-weight: bold;">Sent:</span></b> Mon, March 11, 2013 8:53:15 AM<br><b><span style="font-weight: bold;">Subject:</span></b> Re: mapi.connect / mapi_connect (Second Try)<br></font><br><div
 style="font-family:verdana, helvetica, sans-serif;font-size:10pt;"><div>Then the sample0 program is incorrect, as it passes NULL in the database field.<br></div><div style="font-family:verdana, helvetica, sans-serif;font-size:10pt;"><br><div style="font-family:lucida console, sans-serif;font-size:12pt;"><font face="Tahoma" size="2"><hr size="1"><b><span style="font-weight:bold;">From:</span></b> Fabian Groffen <fabian@monetdb.org><br><b><span style="font-weight:bold;">To:</span></b> developers-list@monetdb.org<br><b><span style="font-weight:bold;">Sent:</span></b> Mon, March 11, 2013 8:35:18 AM<br><b><span style="font-weight:bold;">Subject:</span></b> Re: mapi.connect / mapi_connect (Second Try)<br></font><br>On 11-03-2013 08:30:01 -0700, Stephen P. Morgan wrote:<br>> I wrote an email a few days ago to the effect that I could not get the<br>> mapi.connect()
 MAL statement to work due to the server side complaining that<br>> I had not specified the database to use.<br>> <br>> This morning I ran one of the sample programs included with MonetDB,<br>> clients/examples,C/sample0.c (sample0).  It seems very similar as it issues<br>> a mapi_connect() with the database field set to NULL.  It fails in the same<br>> way, i.e.,<br>> <br>>     MAPI  = monetdb@localhost:50000<br>>     ACTION= mapi_start_talking<br>>     ERROR = !monetdbd: please specify a database<br>> <br>> Should mapi_connect() work with the database field set to NULL?  (If so,<br>> then the mapi.connect() MAL statement should work, I think.)  Is there a bug<br>> in the server that insists on the database being specified?  If there is a<br>> bug, does anyone have a fix for this?  It would be greatly appreciated.<br><br>No, you
 should pass the database name, otherwise the server can't know<br>which one you'd like to connect to.<br><br>-- <br>Fabian Groffen                              <a rel="nofollow" ymailto="mailto:fabian@monetdb.org" target="_blank" href="mailto:fabian@monetdb.org">fabian@monetdb.org</a><br>column-store pioneer               <a rel="nofollow" target="_blank" href="http://www.monetdb.org/Home">http://www.monetdb.org/Home</a><br>_______________________________________________<br>developers-list mailing list<br><a rel="nofollow" ymailto="mailto:developers-list@monetdb.org" target="_blank" href="mailto:developers-list@monetdb.org">developers-list@monetdb.org</a><br><a rel="nofollow" target="_blank" href="http://mail.monetdb.org/mailman/listinfo/developers-list">http://mail.monetdb.org/mailman/listinfo/developers-list</a><br></div></div>



</div></div></div>



</div></body></html>