<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:10pt"><div style="RIGHT: auto"><SPAN style="RIGHT: auto">Hi Sjoerd and Niels,</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto"></SPAN> </div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto">Thank you for the help!</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto"></SPAN> </div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto">It turns out the best way is to install all the openssl-devel, pcre-devel, libxml2-devel.  Compiled those libraries and use them is not easy task, my guess is that the header file is not in default place. The XXX_CFLAGS maybe only used in make phase, not in ./configure phase.</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto"></SPAN> </div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto">Now the database is up and running even with 32 out of 1189 SQL testing fails.</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto"><VAR id=yui-ie-cursor></VAR></SPAN> </div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto">Best Regards,</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto">Hualin</SPAN></div>
<div style="RIGHT: auto"><SPAN style="RIGHT: auto"></SPAN> </div>
<div><BR></div>
<DIV style="FONT-FAMILY: times new roman, new york, times, serif; FONT-SIZE: 10pt">
<DIV style="FONT-FAMILY: times new roman, new york, times, serif; FONT-SIZE: 12pt">
<DIV dir=ltr><FONT size=2 face=Arial>
<DIV style="BORDER-BOTTOM: #ccc 1px solid; BORDER-LEFT: #ccc 1px solid; PADDING-BOTTOM: 0px; LINE-HEIGHT: 0; MARGIN: 5px 0px; PADDING-LEFT: 0px; PADDING-RIGHT: 0px; HEIGHT: 0px; FONT-SIZE: 0px; BORDER-TOP: #ccc 1px solid; BORDER-RIGHT: #ccc 1px solid; PADDING-TOP: 0px" class=hr contentEditable=false readonly="true"></DIV><B><SPAN style="FONT-WEIGHT: bold">From:</SPAN></B> Sjoerd Mullender <sjoerd@acm.org><BR><B><SPAN style="FONT-WEIGHT: bold">To:</SPAN></B> Hualin Wang <sjtuwang@yahoo.com> <BR><B><SPAN style="FONT-WEIGHT: bold">Cc:</SPAN></B> "monetdb-developers@lists.sourceforge.net" <monetdb-developers@lists.sourceforge.net> <BR><B><SPAN style="FONT-WEIGHT: bold">Sent:</SPAN></B> Monday, May 21, 2012 1:11 AM<BR><B><SPAN style="FONT-WEIGHT: bold">Subject:</SPAN></B> Re: [Monetdb-developers] MonetDB on SUSE<BR></FONT></DIV><BR>On 2012-05-19 06:15, Hualin Wang wrote:<BR>> Dear All,<BR>>  <BR>> I have trouble to install the
 right PCRE lib on my SUSE box.<BR>>  <BR>> The server has an old PCRE 7.8 installed.  I compiled my own PCRE 8.3<BR>> version with UTF-8 enabled.<BR>> Then set up the env variables pcre_LIBS, pcre_CFLAGS, PKG_CONFIG_PATH,<BR>>  <BR>> but the ./configure sitll complain utf-8 supported no.<BR>>  <BR>> Which version I should install on the SUSE box?<BR>> Thanks for any hint/help<BR>>  <BR>> Best Regards,<BR>> Hualin<BR><BR>We do not support Suse since we don't have a license.  Having said that,<BR>I did try it out a month or so ago and it did work.  I just used the<BR>Suse SDK to get all necessary libraries.  For PCRE that was<BR>pcre-devel-7.8-2.18.  I have not tried to compile any other versions, so<BR>I can't say for sure what is the problem.<BR><BR>You could take a look at the file config.log and see what it has to say<BR>about the tests that configure does for
 PCRE.<BR><BR>-- <BR>Sjoerd Mullender<BR><BR><BR><BR></DIV></DIV></div></body></html>