<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.3790.4639" name=GENERATOR><LINK 
href="BLOCKQUOTE{margin-Top: 0px; margin-Bottom: 0px; margin-Left: 2em}" 
rel=stylesheet></HEAD>
<BODY style="FONT-SIZE: 10pt; FONT-FAMILY: verdana">
<DIV><FONT face=Verdana size=2>
<DIV>I'm trying to build MonetDB  default branch(HEAD) on Linux, and I have built buildtools, but when I go on </DIV>
<DIV></DIV>
<DIV>with MonetDB, I met some trouble. When run the ./bootstrap under /MonetDB directory, it produces the following </DIV>
<DIV></DIV>
<DIV>errors:</DIV>
<DIV> </DIV>
<DIV></DIV>
<DIV>[root@node1 MonetDB]# ./bootstrap</DIV>
<DIV>automake 1.5 is 1.5 or newer. OK, unless you want to compile with Intel's icc (on Linux), which requires automake </DIV>
<DIV></DIV>
<DIV>1.7 or newer.</DIV>
<DIV>autoconf 2.60 is 2.57 or newer. Good.</DIV>
<DIV>libtool 1.5 is 1.4 or newer. Good.</DIV>
<DIV>Python 2.5.1 is 2.0.0 or newer. Good.</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src/common</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src/common</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src/gdk</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/src/gdk</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/conf</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB/conf</DIV>
<DIV>/root/monetDB/MonetDB/MonetDB</DIV>
<DIV>You should add the contents of `/usr/local/share/aclocal/libtool.m4' to `aclocal.m4'.</DIV>
<DIV>Putting files in AC_CONFIG_AUX_DIR, `conf'.</DIV>
<DIV>aclocal: configure.in: 63: macro `AM_MONETDB_XQ_VARS_1' not found in library</DIV>
<DIV>aclocal: configure.in: 66: macro `AM_MONETDB_DEFAULTS' not found in library</DIV>
<DIV>aclocal: configure.in: 69: macro `AM_MONETDB_COMPILER' not found in library</DIV>
<DIV>aclocal: configure.in: 70: macro `AM_MONETDB_TOOLS' not found in library</DIV>
<DIV>aclocal: configure.in: 71: macro `AM_MONETDB_OPTIONS' not found in library</DIV>
<DIV>aclocal: configure.in: 72: macro `AM_MONETDB_UTILS' not found in library</DIV>
<DIV>aclocal: configure.in: 85: macro `AM_MONETDB_LIBS' not found in library</DIV>
<DIV>aclocal: configure.in: 119: macro `AM_MONETDB_XQ_VARS_2' not found in library</DIV>
<DIV>[root@node1 MonetDB]#</DIV>
<DIV> </DIV>
<DIV></DIV>
<DIV>I must be doing something wrong, but I can't figure out the problem. Any help would be appreciated.</DIV></FONT></DIV>
<DIV><FONT face=Verdana size=2></FONT> </DIV>
<DIV align=left><FONT face=Verdana color=#c0c0c0 size=2>2010-02-06 
</FONT></DIV><FONT face=Verdana size=2>
<HR style="WIDTH: 122px; HEIGHT: 2px" align=left SIZE=2>

<DIV><FONT face=Verdana color=#c0c0c0 size=2><SPAN>zhangyuan</SPAN> 
</FONT></DIV></FONT></BODY></HTML>