developers-list Digest, Vol 52, Issue 1

Stefan Manegold Stefan.Manegold at cwi.nl
Thu Dec 1 13:27:30 CET 2016


As said earlier, if that other ("old"?) database
was created with a MonetDB build without GIS/GEOM support
than simply accessing that database with a new MonetDB build with GIS/GEOM support
does (and can) not add GIS/GEOM functionality to that database.

You need to 
- dump your data from the old database
- create a new database with the new MonetDB build with GIS/GEOM support,
- loaad your dump into that new database.

Best,
Stefan

----- On Dec 1, 2016, at 1:14 PM, Joweria Nakibuuka joweria.nakibuuka at unitn.it wrote:

> But when i try to reach another database as shown below, the module is not
> loaded
> joweria at ubuntu:~$ mserver5 --dbpath=/home/joweria/Spartial/mydbfarm/Gisbase
> !FATAL: GDKlockHome: Database lock '.gdk_lock' denied
> 
> joweria at ubuntu:~$ sudo su
> [sudo] password for joweria:
> root at ubuntu:/home/joweria# mserver5
> --dbpath=/home/joweria/Spartial/mydbfarm/Gisbase
> # MonetDB 5 server v11.24.0
> # This is an unreleased version
> # Serving database 'Gisbase', using 2 threads
> # Compiled for x86_64-unknown-linux-gnu/64bit with 128bit integers
> # Found 1.470 GiB available main-memory.
> # Copyright (c) 1993-July 2008 CWI.
> # Copyright (c) August 2008-2016 MonetDB B.V., all rights reserved
> # Visit http://www.monetdb.org/ for further information
> # Listening for connection requests on mapi:monetdb:// 127.0.0.1:50000/
> # MonetDB/SQL module loaded
>> 
> 
> 
> 2016-12-01 14:09 GMT+02:00 Joweria Nakibuuka < joweria.nakibuuka at unitn.it > :
> 
> 
> 
> 
> 
> joweria at ubuntu:~$ mserver5 --dbpath=/tmp/MyDBfarm/MyDB
> 
> # MonetDB 5 server v11.24.0
> 
> # This is an unreleased version
> 
> # Serving database 'MyDB', using 2 threads
> 
> # Compiled for x86_64-unknown-linux-gnu/64bit with 128bit integers
> 
> # Found 1.470 GiB available main-memory.
> 
> # Copyright (c) 1993-July 2008 CWI.
> 
> # Copyright (c) August 2008-2016 MonetDB B.V., all rights reserved
> 
> # Visit http://www.monetdb.org/ for further information
> 
> # Listening for connection requests on mapi:monetdb:// 127.0.0.1:50000/
> 
> # MonetDB/GIS module loaded
> 
> # MonetDB/SQL module loaded
> 
> 2016-12-01 13:00 GMT+02:00 < developers-list-request at monetdb.org > :
> 
> 
> Send developers-list mailing list submissions to
> developers-list at monetdb.org
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> https://www.monetdb.org/mailman/listinfo/developers-list
> or, via email, send a message with subject or body 'help' to
> developers-list-request at monetdb.org
> 
> You can reach the person managing the list at
> developers-list-owner at monetdb.org
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of developers-list digest..."
> 
> 
> Today's Topics:
> 
> 1. RE: Need Help on enabling GIS (MonetDB/GIS) module in MonetDB
> (Joweria Nakibuuka)
> 2. Re: Need Help on enabling GIS (MonetDB/GIS) module in MonetDB
> (Stefan Manegold)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Thu, 1 Dec 2016 12:11:49 +0200
> From: Joweria Nakibuuka < joweria.nakibuuka at unitn.it >
> To: developers-list at monetdb.org
> Subject: RE: Need Help on enabling GIS (MonetDB/GIS) module in MonetDB
> Message-ID:
> <CANbNUqbw+N3= tb929XArQ8q+AiCG-o5DYNR9Ndk2POChHpdi1g at mail.gmail.com >
> Content-Type: text/plain; charset="utf-8"
> 
> Dear Admin,
> I am running Ubuntu linux 14.04 LTS, x86_64-Ubuntu-linux-gnu/64bit with
> 128bit integers. i recently installed MonetDB5 default branch from the
> mercurial repository.
> 
> I tried to rebuild and enable geom module but to no avail, it shows no
> error, after compilation it shows that the module is enabled,However when i
> run the mserver the monetDB/GIS module is not loaded as expected. I am
> stuck and i don't seem to know how to proceed forward in order to run my
> spatial queries
> 
> Are there any setting i need to do explicitly to load this module?
> 
> the command i used: ./configure --prefix=/home/joweria/MonetDB-Nov2016-SP4
> --enable-geom=yes --enable-pyintegration=yes --with-geos=yes
> 
> and then after compilation under the LDFLAGS-enabled componets
> geom is one of the enabled componet but when i run the mserver5 the module
> is not loaded as expected.
> 
> I rebuild monetDB again and for first time i run the mserver5 commans
> and the GIS module was successfully loaded ie (MonetDB/SQL/GIS module is
> loaded) but when i closed the session (\q) and ran the same command again
> the module was not loaded. i tried exporting paths to no avail. what could
> be the problem? please i need your kind help.
> 
> Thank you
> 
> Regards,
> Joweria nakibuuka
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> http://www.monetdb.org/pipermail/developers-list/attachments/20161201/4fd1b5c0/attachment-0001.html
> >
> 
> ------------------------------
> 
> Message: 2
> Date: Thu, 1 Dec 2016 11:38:17 +0100 (CET)
> From: Stefan Manegold < Stefan.Manegold at cwi.nl >
> To: Communication channel for developers of the MonetDB
> < developers-list at monetdb.org >
> Subject: Re: Need Help on enabling GIS (MonetDB/GIS) module in MonetDB
> Message-ID: < 1362479963.605014.1480588697351.JavaMail.zimbra at cwi.nl >
> Content-Type: text/plain; charset=utf-8
> 
> 
> Hi,
> 
> could you please run the following command twice and share the output of both
> runs?
> 
> mserver5 --dbpath=/tmp/MyDBfarm/MyDB </dev/null
> 
> Thanks!
> Best,
> Stefan
> 
> ----- On Dec 1, 2016, at 11:11 AM, Joweria Nakibuuka joweria.nakibuuka at unitn.it
> wrote:
> 
>> Dear Admin,
>> I am running Ubuntu linux 14.04 LTS, x86_64-Ubuntu-linux-gnu/64bit with 128bit
>> integers. i recently installed MonetDB5 default branch from the mercurial
>> repository.
>> 
>> I tried to rebuild and enable geom module but to no avail, it shows no error,
>> after compilation it shows that the module is enabled,However when i run the
>> mserver the monetDB/GIS module is not loaded as expected. I am stuck and i
>> don't seem to know how to proceed forward in order to run my spatial queries
>> 
>> Are there any setting i need to do explicitly to load this module?
>> 
>> the command i used: ./configure --prefix=/home/joweria/MonetDB-Nov2016-SP4
>> --enable-geom=yes --enable-pyintegration=yes --with-geos=yes
>> 
>> and then after compilation under the LDFLAGS-enabled componets
>> geom is one of the enabled componet but when i run the mserver5 the module is
>> not loaded as expected.
>> 
>> I rebuild monetDB again and for first time i run the mserver5 commans and the
>> GIS module was successfully loaded ie (MonetDB/SQL/GIS module is loaded) but
>> when i closed the session (\q) and ran the same command again the module was
>> not loaded. i tried exporting paths to no avail. what could be the problem?
>> please i need your kind help.
>> 
>> Thank you
>> 
>> Regards,
>> Joweria nakibuuka
>> 
>> _______________________________________________
>> developers-list mailing list
>> developers-list at monetdb.org
>> https://www.monetdb.org/mailman/listinfo/developers-list
> 
> --
>| Stefan.Manegold at CWI.nl | DB Architectures (DA) |
>| www.CWI.nl/~manegold/ | Science Park 123 (L321) |
>| +31 (0)20 592-4212 | 1098 XG Amsterdam (NL) |
> 
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> _______________________________________________
> developers-list mailing list
> developers-list at monetdb.org
> https://www.monetdb.org/mailman/listinfo/developers-list
> 
> 
> ------------------------------
> 
> End of developers-list Digest, Vol 52, Issue 1
> **********************************************
> 
> 
> 
> _______________________________________________
> developers-list mailing list
> developers-list at monetdb.org
> https://www.monetdb.org/mailman/listinfo/developers-list

-- 
| Stefan.Manegold at CWI.nl | DB Architectures   (DA) |
| www.CWI.nl/~manegold/  | Science Park 123 (L321) |
| +31 (0)20 592-4212     | 1098 XG Amsterdam  (NL) |


More information about the developers-list mailing list