Need Help on enabling GIS (MonetDB/GIS) module in MonetDB

Stefan Manegold Stefan.Manegold at cwi.nl
Thu Dec 1 11:38:17 CET 2016


Hi,

could you please run the following command twice and share the output of both runs?

mserver5 --dbpath=/tmp/MyDBfarm/MyDB </dev/null

Thanks!
Best,
Stefan

----- On Dec 1, 2016, at 11:11 AM, Joweria Nakibuuka joweria.nakibuuka at unitn.it wrote:

> Dear Admin,
> I am running Ubuntu linux 14.04 LTS, x86_64-Ubuntu-linux-gnu/64bit with 128bit
> integers. i recently installed MonetDB5 default branch from the mercurial
> repository.
> 
> I tried to rebuild and enable geom module but to no avail, it shows no error,
> after compilation it shows that the module is enabled,However when i run the
> mserver the monetDB/GIS module is not loaded as expected. I am stuck and i
> don't seem to know how to proceed forward in order to run my spatial queries
> 
> Are there any setting i need to do explicitly to load this module?
> 
> the command i used: ./configure --prefix=/home/joweria/MonetDB-Nov2016-SP4
> --enable-geom=yes --enable-pyintegration=yes --with-geos=yes
> 
> and then after compilation under the LDFLAGS-enabled componets
> geom is one of the enabled componet but when i run the mserver5 the module is
> not loaded as expected.
> 
> I rebuild monetDB again and for first time i run the mserver5 commans and the
> GIS module was successfully loaded ie (MonetDB/SQL/GIS module is loaded) but
> when i closed the session (\q) and ran the same command again the module was
> not loaded. i tried exporting paths to no avail. what could be the problem?
> please i need your kind help.
> 
> Thank you
> 
> Regards,
> Joweria nakibuuka
> 
> _______________________________________________
> developers-list mailing list
> developers-list at monetdb.org
> https://www.monetdb.org/mailman/listinfo/developers-list

-- 
| Stefan.Manegold at CWI.nl | DB Architectures   (DA) |
| www.CWI.nl/~manegold/  | Science Park 123 (L321) |
| +31 (0)20 592-4212     | 1098 XG Amsterdam  (NL) |


More information about the developers-list mailing list