Need Help on enabling GIS (MonetDB/GIS) module in MonetDB

Joweria Nakibuuka joweria.nakibuuka at unitn.it
Thu Dec 1 11:11:49 CET 2016


Dear Admin,
I am running Ubuntu linux 14.04 LTS, x86_64-Ubuntu-linux-gnu/64bit with
128bit integers. i recently installed MonetDB5 default branch from the
mercurial repository.

I tried to rebuild and enable geom module but to no avail, it shows no
error, after compilation it shows that the module is enabled,However when i
run the mserver the monetDB/GIS module is not loaded as expected. I am
stuck  and i don't seem to know how to proceed forward in order to run my
spatial queries

Are there any setting i need to do explicitly to load this module?

the command i used: ./configure --prefix=/home/joweria/MonetDB-Nov2016-SP4
--enable-geom=yes --enable-pyintegration=yes --with-geos=yes

and then after compilation under the  LDFLAGS-enabled componets
geom is one of the enabled componet but when i run the mserver5 the module
is not loaded as expected.

I rebuild monetDB  again and for  first time i run the  mserver5 commans
and the GIS module was successfully loaded ie (MonetDB/SQL/GIS module is
loaded) but when i closed the session (\q) and ran the same command again
the module was not loaded. i tried exporting paths to no avail. what could
be the problem? please i  need your kind help.

Thank you

Regards,
Joweria nakibuuka
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.monetdb.org/pipermail/developers-list/attachments/20161201/4fd1b5c0/attachment.html>


More information about the developers-list mailing list