MonetDB configured with "--program-suffix" does not start DBs

Sjoerd Mullender sjoerd at monetdb.org
Sat Jun 22 09:48:07 CEST 2013


Please report as bug (or rather enhancement request) at bugs.monetdb.org.
We don't (currently) support --program-suffix, --program-prefix, or
--program-transform-name.

On 2013-06-22 02:50, Benjamin Reilly wrote:
> Hi all,
> 
> I downloaded a copy of the 11.15.7 (Feb2013 SP2) source and compiled and
> installed it. I also have a copy of the same version of MonetDB
> installed from elsewhere (I'm not sure where now--sorry).
> 
> Now, when I run the "old" version of Monet (the one I didn't just
> compile) and create a DB (`monetdb create test`), release it, and start
> it, everything works fine. The log looks likes this:
> 
> ...
> MSG merovingian[32695]: starting database 'test', up min/avg/max:
> 0s/0s/0s, crash average: 0.00 0.00 0.00 (0-0=0)
> MSG control[32695]: (local): started 'test'
> MSG test[32705]: arguments: */usr/local/bin/m**server5** ...<snip>...*
> ...
> 
> However, when I run with my compiled version (using `configure
> --program-suffix=-vanilla`), starting a created DB does not call
> mserver5-vanilla, but rather monetdbd-vanilla, which is the incorrect
> command, and thus the database cannot start. (If I manually run
> mserver5-vanilla, it works fine.) The log looks like this:
> 
> MSG merovingian[2616]: starting database 'test', up min/avg/max:
> 0s/0s/0s, crash average: 0.00 0.00 0.00 (0-0=0)
> MSG test[2625]: arguments:
> */usr/local/bin/monetd**bd-vanilla** ...<snip>...*
> MSG test[2625]: usage: monetdbd [ command [ command-options ] ] <dbfarm>
> MSG test[2625]:   where command is one of:
> MSG test[2625]:     create, start, stop, get, set, version or help
> MSG test[2625]:   use the help command to get help for a particular command
> MSG test[2625]:   The dbfarm to operate on must always be given to
> MSG test[2625]:   monetdbd explicitly.
> ERR test[2625]: monetdbd: unknown command:
> --dbpath=/home/breilly/db/farm-vanilla/test
> MSG merovingian[2616]: database 'test' (2625) has exited with exit status 1
> ERR control[2616]: (local): failed to fork mserver: database 'test'
> appears to shut itself down after starting, check monetdbd's logfile for
> possible hints
> 
> I tried just now to compile without the suffix, but in a different
> directory (i.e. `configure --prefix=$HOME/apps`), and it worked fine, as
> with the first version above. I'm not sure why the one with the suffix
> fails in the way it does: it's not like it tries to find "mserver5"
> (without the suffix) and fails. Instead, it successfully finds a real
> command with the suffix, but it's the wrong one.
> 
> I have also tried simply symlinking to my suffixed program with
> non-suffixed name (i.e. `ln -s $HOME/apps/bin/monetdbd-vanilla
> $HOME/apps/bin/monetdb`, for each of monetdbd, monetdb, mclient, and
> mserver5), and this also works. However, it does not run the correct
> version of mserver5: it runs /usr/local/bin/mserver5, rather than my
> local copy at $HOME/apps/bin/mserver5. Is there some environment
> variable that I'm not setting correctly? ($HOME/apps/bin is in my PATH).
> 
> Please let me know if there is any more information that I can provide
> for you. Thanks in advance for your help.
> 
> Regards,
> Ben Reilly
> 
> 
> _______________________________________________
> developers-list mailing list
> developers-list at monetdb.org
> http://mail.monetdb.org/mailman/listinfo/developers-list
> 


-- 
Sjoerd Mullender

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 373 bytes
Desc: OpenPGP digital signature
URL: <http://www.monetdb.org/pipermail/developers-list/attachments/20130622/3f52e08e/attachment.sig>


More information about the developers-list mailing list