Problem running web app using latest jdbc driver

Casey Gum casey.gum at gmail.com
Tue Jul 2 23:52:53 CEST 2013


I have a RESTful web service that stores its information in MonetDB.  I
have to run in a Java 1.6 environment.  The latest version of the jdbc
driver says that it is for both 1.6 and 1.7.

I'm getting the dependency resolved through maven using the clojars
repository

*      <repository>*
*            <id>monetdb</id>*
*            <url>http://repository.pentaho.org/artifactory/repo</url>*
*            <snapshots>*
*                <enabled>false</enabled>*
*            </snapshots>*
*        </repository>*

My dependency block looks like this:

*        <dependency>*
*            <groupId>monetdb</groupId>*
*            <artifactId>monetdb-jdbc</artifactId>*
*            <version>2.9</version>*
*        </dependency>*


Everything worked when I was running v2.8 and getting my dependency
resolved from the pentaho repository, but when I get the dependency from
clojars, I get the following error:

*java.lang.UnsupportedClassVersionError: nl/cwi/monetdb/jdbc/MonetDriver :
Unsupported major.minor version 51.0*
*
*
Two questions:

1.  Should the 2.9 version work under Java 1.6?
2.  Is there some setting I need to put in my pom.xml file so that it runs
in "1.6 compatibility mode" or something?

Thanks,

Casey Gum
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.monetdb.org/pipermail/developers-list/attachments/20130702/bb2edeef/attachment.html>


More information about the developers-list mailing list