[Monetdb-developers] BATpreload_ and _BATpreload
sjoerd at acm.org
Mon Feb 15 10:03:18 CET 2010
On 2010-02-15 09:57, Stefan Manegold wrote:
> On Sun, Feb 14, 2010 at 09:21:34PM +0100, Martin Kersten wrote:
>> Sjoerd Mullender wrote:
>>> I am quite unhappy with the names BATpreload, BATpreload_, and
>>> _BATpreload. I really don't like names that differ only by an initial
>>> or final _. I would much rather see more descriptive names.
>>> BATpreload_ is now more an interface to give advice to the underlying
>>> system about how the BAT is going to be accessed in the near future, and
>>> _BATpreload is telling the underlying system that you're done with
>>> accessing the BAT according to the advice given. Names such as
>>> BATaccessadvice/BATendaccessadvice, though longer, are more descriptive.
>>> I have seen some checkins fixing the incorrect use of BATpreload_ and
>>> _BATpreload, proofing my point.
>>> Now we still have a chance to fix this.
>> I fully agree, but did not had the trigger to change it....
> I also more than agree --- what about
> BATaccessBegin() & BATaccessEnd() ?
> If noone else is "faster", I could apply the chnages later today ...
That's good. What about BATpreload (without _)?
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 371 bytes
Desc: OpenPGP digital signature
More information about the developers-list