[Monetdb-developers] BATpreload_ and _BATpreload
sjoerd at acm.org
Sun Feb 14 21:15:42 CET 2010
I am quite unhappy with the names BATpreload, BATpreload_, and
_BATpreload. I really don't like names that differ only by an initial
or final _. I would much rather see more descriptive names.
BATpreload_ is now more an interface to give advice to the underlying
system about how the BAT is going to be accessed in the near future, and
_BATpreload is telling the underlying system that you're done with
accessing the BAT according to the advice given. Names such as
BATaccessadvice/BATendaccessadvice, though longer, are more descriptive.
I have seen some checkins fixing the incorrect use of BATpreload_ and
_BATpreload, proofing my point.
Now we still have a chance to fix this.
More information about the developers-list