[Monetdb-developers] release show stopper

Sjoerd Mullender sjoerd at acm.org
Wed May 27 21:01:02 CEST 2009


I have a serious problem with the release on Windows.

If I first install the old (April 2009, ie Feb2009-SP2) version, create 
a table and insert a value (the latter probably not necessary):

create table foo (s varchar (10));
insert into foo values ('test');

exit client and server, then upgrade to new version, the table gets lost:

sq1>select * from foo;
!SELECT: no such table 'foo'

When I tried this on Linux, it worked.

select * from tables; works and looks good, except that there is no 
mention of the foo table.

So far I've only tried this on 32 bit Windows and 64 bit Fedora 10.  It 
could be that the problem is a 32/64 bit problem, or a Windows/Linux 
problem.  In any case, this is a show stopper.

The problem persists if I first have the logger flush itself before the 
upgrade, so I don't think it's a logger problem.

(On Windows, the log directory is moved automatically by the command 
script.  This works.)

-- 
Sjoerd Mullender




More information about the developers-list mailing list