[Monetdb-developers] problems with starting the monetDB4xquery server

Mtekel thx at trolej.sk
Thu Jun 4 22:02:42 CEST 2009


Hello, I have carefully read the link you have sent me. Too bad comments are
closed. I have now uninstalled my 20090424 version and installed the newest
20090530. However I still have problems running the server.

The 2009 4 24 version wouldn't start even after loading all the modules by
hand from the Mserver interactive commandline - nor the client or browser
would connect. They would just hang, connecting forever.

Now this works for the 05 30 version, but I can't use the web interface
(which now works) for adding the files - I get a bug (I'm not sure If I am
allowed to send attachements, so I'll include them in the next mail).

Adding from commandline, mclient --language=xquery -I %1 -C WOcollection <
%1 , where %1 is filename, works, but the collection name is %1 WOcollection
(e.g. three different files end up in different collections instead of one).

What is more interresting, if I try to run pf:add-doc("DATA_wo3.xml",
"DATA_wo3.xml", "WOcollection", 1) from the client's interactive
commandline, I get this error (no matter where the file really is):

MAPI  = monetdb at localhost:50000
QUERY = pf:add-doc("DATA_wo3.xml", "DATA_wo3.xml", "WOcollection", 1)
ERROR = !ERROR: interpret: no matching MIL operator to 'ws_create(int)'.

I have run procmon and created trace as described in the link, the file is
attached (to the second mail).

I hope this issue can be solved somehow,

Best regards,

Michael

-----Original Message-----
From: Ying Zhang [mailto:Y.Zhang at cwi.nl] 
Sent: 2. júna 2009 10:41
To: Mtekel
Cc: monetdb-developers at lists.sourceforge.net
Subject: Re: [Monetdb-developers] problems with starting the monetDB4xquery
server

Hello Michael,

Thanks for using MonetDB, and sorry for the inconvenience!

Your problem has been reported earlier.  Unfortunately, we don't have a
solution for this problem at this moment.  However, there is a
workaround, which seems to work according to other users.  So please
have a look at the following bug report (the workaround is in the
report):

http://sourceforge.net/tracker/index.php?func=detail&aid=2693363&group_id=56
967&atid=482468

Kind regards,

Jennie

On Mon, Jun 01, 2009 at 10:55:45AM +0200, Mtekel wrote:
> Hello,
> 
> I have problems starting the monetDB xquery server under windowsXP sp3.
When
> I click on the link in the start menu, dos window appears but then it
closes
> immediatelly and I can't see what's there (after pausing I can see only
the
> first 6 lines of the program output as described below, then after
unpausing
> it immediatelly quits and closes the window). If I run MXQserver.bat, or
> Mserver.bat --dbinit="module(pathfinder);" I get only this:
> 
> # MonetDB Server v4.28.4
> # based on GDK   v1.28.4
> # Copyright (c) 1993-July 2008, CWI. All rights reserved.
> # Copyright (c) August 2008-2009, MonetDB B.V.. All rights reserved.
> # Compiled for i686-pc-win32/32bit with 32bit OIDs; dynamically linked.
> # Visit http://monetdb.cwi.nl/ for further information.
> # PF/Tijah module v0.9.0 loaded. http://dbappl.cs.utwente.nl/pftijah
> 
> That's all. The server immediatelly ends. However If I run only
Mserver.bat,
> the server "runs" - I get the prompt, but for example I can't connect to
the
> web interface on the port 50000.
> 
> Does anyone have any advice what to do? How to make it work?
> Any advice appreciated,
> 
> Best regards
> 
> Michael
> 
> 
>
----------------------------------------------------------------------------
--
> Register Now for Creativity and Technology (CaT), June 3rd, NYC. CaT 
> is a gathering of tech-side developers & brand creativity professionals.
Meet
> the minds behind Google Creative Lab, Visual Complexity, Processing, & 
> iPhoneDevCamp as they present alongside digital heavyweights like
Barbarian 
> Group, R/GA, & Big Spaceship. http://p.sf.net/sfu/creativitycat-com 
> _______________________________________________
> Monetdb-developers mailing list
> Monetdb-developers at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/monetdb-developers





More information about the developers-list mailing list