[Monetdb-developers] Re : Cannot get perl talking to monetdb5 nightly stable

Fabian Groffen Fabian.Groffen at cwi.nl
Wed Sep 10 09:23:34 CEST 2008


On 09-09-2008 01:36:21 -0700, sylver_b wrote:
> Hi 
> 
> For the one wondering why the Perl lib doesn't work with monetdb , this
> is the answer from the developer :
> 
> >MonetDB::CLI::MapiPP still speaks protocol version 4, not 5.
> >Maybe the libMapi based MonetDB::CLI::MapiLib works with the
> >current version - I didn't test it.

I think we should remove MapiPP, it can't and won't work any more.  It
seems like a relatively large investment to /make/ it work.

In contrast, Mapi.pm seems to be up-to-date to the latest protocol,
while also being a pure perl implementation.  Can you use Mapi.pm for
your application?




More information about the developers-list mailing list