[Monetdb-developers] Cannot get perl talking to monetdb5 nightly stable

sylver_b sylver_b at yahoo.com
Tue Sep 9 09:24:06 CEST 2008


Hi Everyone,

I'm also experiencing some difficulties with Perl - i've spent the past 3 days trying to get this to work but i can't find any log, any error message etc ...

I've installed all the perl libs , but when i run the test script, it's just stay there indefinitely with no output,no error - this is the script :
cat monetdb2.pl

#!/usr/bin/perl

use DBI();

  my $dbh = DBI->connect('dbi:monetdb:');

  my $sth = $dbh->prepare('SELECT * FROM env');
  $sth->execute;
  $sth->dump_results;

I'm running monetdb with the following command:
root at ulys:~# mserver5 --dbinit="include sql;" --dbname=demo --daemon=yes
# MonetDB server v5.6.0, based on kernel v1.24.0
# Serving database 'demo'
# Compiled for i686-pc-linux-gnu/32bit with 32bit OIDs dynamically linked
# Copyright (c) 1993-2008 CWI, all rights reserved
# Visit http://monetdb.cwi.nl/ for further information
#warning: please don't forget to set your vault key!
#(see /root/MonetDB/etc/monetdb5.conf)
# Listening for connection requests on mapi:monetdb://127.0.0.1:50000/
# MonetDB/SQL module v2.24.0 loaded

when i kill the monetdb daemon, my perl script is throwing this error :
# ./monetdb2.pl
Caught a SIGPIPE at /usr/local/share/perl/5.8.8/MonetDB/CLI/MapiPP.pm line 93
$ = eval {...} called from file `/usr/local/share/perl/5.8.8/MonetDB/CLI/MapiPP.pm' line 93
$ = MonetDB::CLI::MapiPP::Req::query('MonetDB::CLI::MapiPP::Req=HASH(0x83a66e0)', 'SELECT * FROM env') called from file `/usr/local/share/perl/5.8.8/DBD/monetdb.pm' line 567
$ = eval {...} called from file `/usr/local/share/perl/5.8.8/DBD/monetdb.pm' line 567
$ = DBD::monetdb::st::execute('DBI::st=HASH(0x83a683c)') called from file `./monetdb2.pl' line 8
Aborted

Also i can connect with no problem with mclient (no password required).

Please advise on how to get perl talking to monetdb5.

Thanks in advance,
SB
 
------ original message -------

[Monetdb-developers] Cannot get perl talking to monetdb5 nightly stableFrom: Rt Ibmer <rtibmx at ya...> - 2008-06-17 02:06 
I am using the nightly stable build of monetdb5. All outside of perl->monetdb seems to
be working just fine. I just can't get perl to talk to the db.

Here's what I did:

- installed from nightly stable source on Fedora 8

- copied the source from http://homepages.cwi.nl/~mk/MonetDB/The-Perl-Library.html into
mytest.pl

- tried running: perl /tmp/mytest.pl

but it came back complaining about missing libs in @INC.

So then I added these steps:

- /var/tmp/MonetDB-1213632062/MonetDB-client/clients/src/perl
- make install
and also ran make instlal in the various subdirs like MonetDB-CLI and others (not sure if
this step was necessar)

Then I tried running the script and this time it executed without the @INC errors. So this
was progress.

However all I get is this:
-------
Start a simple Monet MIL interaction

data sources: dbi:monetdb:
--------

and then nothing. It just sits there indefinitely. In playing with the source of the .pl I
see that it is the "my $dbh = DBI->connect( $dsn, ..."
that execution stops at. 

I have merovingian running and the db is started. I also tried with merovigan stopped and
just using mserver5 --dbinit="include sql;" but I had the same result.

Am I doing something wrong? Thanks. 


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.monetdb.org/pipermail/developers-list/attachments/20080909/d0940b90/attachment.html>


More information about the developers-list mailing list