[Monetdb-developers] Mtest: remove M5 warning about modules

Fabian Groffen Fabian.Groffen at cwi.nl
Tue Nov 11 11:42:38 CET 2008


Currently Mtest.py spits out the following warning when using M5:

Mtest.py  Warning:  MonetDB/5: Check, whether required modules do exist,
is not possible, yet!

It's in there for years.

I think the functionality of Mtest to be able to check whether required
modules are available before running a test come at the price of
administering which modules are necessary to run the test.  Implementing
the module check in M5 hence would also mean adding the required module
information to each test.

Hence, I would suggest to remove the warning from Mtest.py and just deal
with the error messages that appear when modules don't exist.

Opinions?




More information about the developers-list mailing list