[Monetdb-developers] php5 interface

Martin Kersten Martin.Kersten at cwi.nl
Fri May 9 20:00:53 CEST 2008


Michiel Kamermans wrote:
> Martin,
>
> A test using windows XP with PHP 5.2.6 and MonetDB seems to work just 
> fine. I suspect that this means that in Vista monetDB won't be able to 
> interface with PHP either, as the core is essentially the same as the 
> one used in windows server 2008... I am not a windows expert myself 
> when it comes to figuring out API differences, so I wouldn't know 
> where to look... but I do have one improvement to the php file in the 
> /share/php dir:
>
> Right now it auto-assumes running on *nix, automatically calling 
> dl('monetdb.so'). A change for this line to the following would make 
> the script usable on both *nix and windows:
>
> $ext="monetdb";
> if (!extension_loaded($ext)) {
>    $prefix = (PHP_SHLIB_SUFFIX === 'dll') ? 'php_' : '';
>    dl($prefix . $ext . '.' . PHP_SHLIB_SUFFIX); }
>
> Regards,
Thank you very much for the information provided, we will take this 
suggestion into consideration
>
> Mike Kamermans
> (who will now no doubt spend a nice bit of time in XP doing 
> benchmarking =)





More information about the developers-list mailing list