[Monetdb-developers] load runtime incorrectly

mobigital-nbl at yahoo.com mobigital-nbl at yahoo.com
Thu Feb 28 04:34:52 CET 2008


FYI, this issue turned out to be due to the linking to non-debug MSVCR90.lib in:

1. iconv project. - had to make sure that MDFlags in iconv makefile also changed to /MDd when debug was requested.
2. pthreads - changed /MD to /MDd in flags to each .c compilation to .obj, also added /MDd in final linking and removed explicit linking with libcrt.lib - because /MDd already does it with debug crt.



 
> additional info:
> 
> it seems even after DEBUG build, my executable is looking for non-DEBUG version 
> of MSVCR90.dll
> 
> ---------------------------
> mserver5.exe - Unable To Locate Component
> ---------------------------
> This application has failed to start because MSVCR90.dll was not found. 
> Re-installing the application may fix this problem. 
> ---------------------------
> 
> when i copy the set of MSVCR90.dll and manifest into debug directory, i get the 
> error shown below.(my prior message)
> 
> here are my build commands that i use for all modules:
> 
> nmake /nologo BITS64=1 NEED_MX=1 DEBUG=1 HAVE_ICONV=1 HAVE_MONETDB4=1 
> HAVE_MONETDB5=1 HAVE_PYTHON=1 "prefix=%BUILDTOOLS_PREFIX%"
> 
> nmake /nologo BITS64=1 NEED_MX=1 DEBUG=1 HAVE_ICONV=1 HAVE_MONETDB4=1 
> HAVE_MONETDB5=1 HAVE_PYTHON=1 "prefix=%BUILDTOOLS_PREFIX%" install
> 
> > 
> > Does anyone know why i may be getting this error:
> > 
> > Runtime Error!
> > 
> > Program: C:\monetdb\build\bin\mserver5.exe
> > 
> > R6034
> > 
> > An application has made an attempt to load the C runtime library incorrectly.
> > Please contact the application's support team for more information.
> > 
> > -----------
> > also is there a 'clean' target for make? 
> > i don't see it anywhere.
> > 
> > 







More information about the developers-list mailing list