[Monetdb-developers] what about the jdbc driver ?

Fabian2 fabian at cwi.nl
Fri Feb 1 10:06:26 CET 2008



Jean-Paul Le Fèvre-2 wrote:
> 
>   
> Hello,
> 
> I'm unable to compile the jdbc driver : some Monet classes do not
> implement 
> abstract methods. I've read a previous thread about this problem in the 
> archive from april 2007. The cause of the problem seems to be the version
> of 
> java I'm using (1.6). In my opinion jdk 1.5 is obsolete at this point and
> I 
> no longer have this version on any of my machines.
> 

I'm sorry, but J2EE is still at version 1.5, and hence far from obsolete.

However the 1.6+ (a.k.a. JDBCv4) implementation doesn't add anything but
some SQL/XML stuff and takes some time to implement (boring work of adding a
lot of empty/non-implementable methods), which I currently don't have.

Feel free to use the latest pre-compiled driver from
http://www.cwi.nl/~fabian/troep/jdbcclient.jar
-- 
View this message in context: http://www.nabble.com/what-about-the-jdbc-driver---tp15205472p15222910.html
Sent from the monetdb-developers mailing list archive at Nabble.com.





More information about the developers-list mailing list