[Monetdb-developers] XRPCwrapper fails to compile with java 1.4

Fabian Groffen Fabian.Groffen at cwi.nl
Tue Oct 16 08:08:36 CEST 2007


On 16-10-2007 07:44:47 +0200, Stefan Manegold wrote:
> Hoi,

Hi,

> I don't consider the fact that our RedHat 4WS machine (titan) has only Java
> 1.4 a limiting factor and/or reason to for the support of anchient Java 1.4.
> My main point was to make the software requirements for MonetDB quite clear.
> Apparently, Java 1.4 is no longer sufficient to compile all part of the
> MonetDB SW collection. Hence, we should tighten the requirements
> accordingly. Apparently, Java 1.5 seems to be the only version that allows
> to compile all MonetDB relates Java code successfully. On systems that do
> not have Java 1.5, but only Java <= 1.4 (e.g., RedHat 4WS on Itanium) or
> only Java >= 1.6, the MonetDB-related Java code can hence not be compiled.
> Since we know this, configure should say so instead of make failing with
> some strange error.

Yeah, and my main point is that it seems unreasonable to me to *have* to
use *one* configure check for all sub-projects involved.  clients can
remain as-is.  pathfinder just needs a check for 1.5 and up.  Forcing
1.5 for all sub-projects sounds unreasonable and pointless to me.

> Unfortunately, it's too late for this release, but the will be a next
> (bug-fix) release.

Neither did I want to suggest so.




More information about the developers-list mailing list