[Monetdb-developers] XRPCwrapper fails to compile with java 1.4

Stefan Manegold Stefan.Manegold at cwi.nl
Tue Oct 16 07:44:47 CEST 2007


Hoi,

I don't consider the fact that our RedHat 4WS machine (titan) has only Java
1.4 a limiting factor and/or reason to for the support of anchient Java 1.4.
My main point was to make the software requirements for MonetDB quite clear.
Apparently, Java 1.4 is no longer sufficient to compile all part of the
MonetDB SW collection. Hence, we should tighten the requirements
accordingly. Apparently, Java 1.5 seems to be the only version that allows
to compile all MonetDB relates Java code successfully. On systems that do
not have Java 1.5, but only Java <= 1.4 (e.g., RedHat 4WS on Itanium) or
only Java >= 1.6, the MonetDB-related Java code can hence not be compiled.
Since we know this, configure should say so instead of make failing with
some strange error.
Unfortunately, it's too late for this release, but the will be a next
(bug-fix) release.

Stefan

On Mon, Oct 15, 2007 at 11:12:47AM +0200, Fabian Groffen wrote:
> On 15-10-2007 11:02:09 +0200, Ying Zhang wrote:
> > On Mon, Oct 15, 2007 at 10:14:56AM +0200, Fabian Groffen wrote:
> > > On 15-10-2007 10:11:51 +0200, Martin Kersten wrote:
> > > > > My analysis:
> > > > >
> > > > > JDBC needs 1.4<=java<~1.5
> > > > > XRPCwrapper needs java>=1.5 due to usage of XML standard libraries
> > > > >   
> > > > Intersection is 1.5 ? and sufficient to work?
> > > 
> > > You suggest to force XRPC users to have 1.5 for no reason?
> > 
> > Did you mean "to force JDBC users to have 1.5 for no reason"?
> > Because XRPC wrapper users will certainly have to use 1.5
> 
> You force JDBC users to use 1.5, and you force XRPC users to use 1.5.
> The former could have been satisfied with 1.4 (industrial settings may
> have this still as the latest "reliable" version), whereas the latter
> could have been satisfied with 1.6 or 1.7.  As Sjoerd pointed out, 1.4
> is anchient, so people having 1.6 these days is quite normal.
> 
> > > XRPC is pulled out of the clients repo now, so I don't see any reason
> > > why it should be tied to the same configure check as we do for clients.
> > 
> > You are right.  In the bug-fix release, I would like to add a check for
> > Java version, but this doesn't affect JDBC.
> > Making XRPC wrapper Java 1.4 compatable is not a (good) option...
> 
> your build.properties says you minimally require 1.4 iirc.
> 
> > Why is the Redhat machine not upgraded to Java 1.5?
> 
> That is a workaround ;)  But there is a 1.5 installed for the Bond demo.
> It isn't upgraded, because Sun doesn't provide an 1.5 for Itanium.

-- 
| Dr. Stefan Manegold | mailto:Stefan.Manegold at cwi.nl |
| CWI,  P.O.Box 94079 | http://www.cwi.nl/~manegold/  |
| 1090 GB Amsterdam   | Tel.: +31 (20) 592-4212       |
| The Netherlands     | Fax : +31 (20) 592-4312       |




More information about the developers-list mailing list