[Monetdb-developers] XRPCwrapper fails to compile with java 1.4

Fabian Groffen Fabian.Groffen at cwi.nl
Mon Oct 15 10:03:29 CEST 2007


On 15-10-2007 09:29:29 +0200, Stefan Manegold wrote:
> Hoi,
> 
> apparently, the new XPRCwrapper code fails to compile with java 1.4 (our
> RedHat 4 WS machine, titan, is the only testing machine that still has only
> java 1.4, all others have java 1.5); for details see below and/or
> http://monetdb.cwi.nl/testing/projects/monetdb/Stable/pathfinder/.ntv.64.64.d-RedHat4WS/make.out
> 
> Question:
> Assuming that there is no easy way to make the new XRPC warpper code java
> 1.4 compliant: should we modify (tighten) our requirements accordingly,
> i.e., requiring (only) java 1.5 instead of (at least) java 1.4 to build
> MonetDB* (java 1.6 is not (yet?) supported)?

My analysis:

JDBC needs 1.4<=java<~1.5
XRPCwrapper needs java>=1.5 due to usage of XML standard libraries
introduced in Java 1.5  (See the API, which has @since.)

Jennie's build file doesn't correctly state this dependency, but also
the JDBC configure check is invalid for XRPCwrapper.

JDBC can't use java>=1.6 (yet) because 1.6 introduced a new interface
version of JDBC, v4, which backwards incompatible with the currently
implemented interface v3.  I once started on a branch to work around
this a bit, but it is just a lot of work and I guess my code changes out
of date by now given the code was fixed in some points.




More information about the developers-list mailing list