[Monetdb-developers] [Monetdb-pf-checkins] pathfinder/modules/pftijah nexi.c, 1.57, 1.58 nexi_generate_mil.c, 1.27, 1.28 pftijah.mx, 1.116, 1.117

Jan Flokstra flokstra at cs.utwente.nl
Mon May 7 09:19:17 CEST 2007


On Monday 07 May 2007 09:09, Stefan Manegold wrote:
> On Mon, May 07, 2007 at 07:01:43AM +0000, Jan Flokstra wrote:
> > Update of /cvsroot/monetdb/pathfinder/modules/pftijah
> > In directory sc8-pr-cvs16:/tmp/cvs-serv20990/modules/pftijah
> >
> > Modified Files:
> > 	nexi.c nexi_generate_mil.c pftijah.mx
> > Log Message:
> > * Implement private term- and tag dictionaries. Default is still the
> > global version so nothing changed yet in the format. I'm having terrible
> > trouble with the Mtest's again. This version could not be tested by our
> > Mtest tests because the first query executes OK but all queries after
> > that seem to 'forget' the instance variables of module pftijah. I will
> > look if the same happens on other machine and post a bugreport for it.
>
> does the same happen if you run the test(s) by hand i.e., without Mtest?

No, without Mtest the queries run OK. eg, any FIRST query runs OK. Any query 
after this fails.

>
> How do the queries and the test script(s) look like?

The normal 28 tests from $PF/modules/pftijah/Tests So a mix of mil scripts 
and .xq XQueries.

> How do you (successfully?) run them by hand?

Just run the scripts in a test directory using MapiClient (-lx)
> How do you (unsuccesfully) run them via Mtest?

Mtest.py -d0 --TSTSRCBASE /local/flokstra/software/pathfinder

in directory /local/flokstra/software/pathfinder/modules/pftijah

>
> Stefan

The text of the bug report I had in  mind was:
====================================================
I am having Mtest module variable problems again with pftijah. It looks a
little bit like the never really solved problem of bug:

[ 1638729 ] Mtest/Mapi module load problem

The problem here was that the module was loaded but the instance variables
and the non-ADDHELP'ed functions were unknown. We solved this by loading
pftijah always from pathfinder but did not find the cause of the problem.

I'm now having the same problem but in a different form. When I use Mtest
on the pftijah Testset the first test where module(pftijah) is used works
fine. But all tests after this fail. The problem is again that the MIL
functions in the module are executed but the functions do not know the
instance variables of the module. Nearly all tests fail on the variables
"verbose" and "dflt_ft_index".
You can for instance check this by changing $PF/modules/pftijah/Tests/All
The first test which normally fails is createcoll0 because it is the
second test. But when you remove loadthesis from All createcoll0 succeeds
and createcoll1, which is then the second, fails.

====================================================

Jan.




More information about the developers-list mailing list