[Monetdb-developers] M4 compilation

Romulo Goncalves R.A.Goncalves at cwi.nl
Wed Jan 17 18:38:51 CET 2007


I updated all MonetDB background (buildtools, MonetDB, clients)

I just checked out M4 and during the compilation I got the error:

gcc -m64 -DHAVE_CONFIG_H -I. -I/ufs/goncalve/MonetDB/MonetDB4/src/tools 
-I../.. -I/ufs/goncalve/MonetDB/MonetDB4/src/tools 
-I/ufs/goncalve/scratch/MonetDB/MonetDB/include/MonetDB 
-I/ufs/goncalve/scratch/MonetDB/MonetDB/include/MonetDB/common 
-I/ufs/goncalve/scratch/MonetDB/MonetDB/include/MonetDB/gdk 
-I/ufs/goncalve/scratch/MonetDB/clients/include/MonetDB 
-I/ufs/goncalve/scratch/MonetDB/clients/include/MonetDB/mapilib 
-I../monet -I/ufs/goncalve/MonetDB/MonetDB4/src/tools/../monet 
-I../modules/plain 
-I/ufs/goncalve/MonetDB/MonetDB4/src/tools/../modules/plain    -Wall -W 
-std=c99 -g -Werror-implicit-function-declaration -Werror 
-Wno-unused-function -Wno-unused-label  -D_REENTRANT -c Mserver.c
/ufs/goncalve/MonetDB/MonetDB4/src/tools/Mserver.mx: In function 
‘Monet_init’:
/ufs/goncalve/MonetDB/MonetDB4/src/tools/Mserver.mx:173: error: 
‘GDK_mem_pagebits’ undeclared (first use in this function)
/ufs/goncalve/MonetDB/MonetDB4/src/tools/Mserver.mx:173: error: (Each 
undeclared identifier is reported only once
/ufs/goncalve/MonetDB/MonetDB4/src/tools/Mserver.mx:173: error: for each 
function it appears in.)
make[5]: *** [Mserver.o] Error 1
make[5]: Leaving directory 
`/net/gio/export/scratch0/goncalve/MonetDB/MonetDB4/build/src/tools'
make[4]: *** [all] Error 2
make[4]: Leaving directory 
`/net/gio/export/scratch0/goncalve/MonetDB/MonetDB4/build/src/tools'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory 
`/net/gio/export/scratch0/goncalve/MonetDB/MonetDB4/build/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory 
`/net/gio/export/scratch0/goncalve/MonetDB/MonetDB4/build/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory 
`/net/gio/export/scratch0/goncalve/MonetDB/MonetDB4/build'
make: *** [all] Error 2
[goncalve at gio ~]$


In the Path I have buildtools_prefix/bin MonetDB_prefix/bin and 
clients_prefix/bin

Is any trick that I should do to resolve this problem?

Note:
The prefix of M4 is different from MonetDB.

Regards,
Romulo




More information about the developers-list mailing list