[Monetdb-developers] bootstrapping problems on HEAD

Jan Flokstra flokstra at cs.utwente.nl
Fri Jan 12 15:07:33 CET 2007


On Friday 12 January 2007 15:00, Sjoerd Mullender wrote:
[...]
>
> Doesn't really matter.  It seems to key point is that Jan runs configure
> in the source directory.  We always use a separate build directory.
>
> When I try configure in the source directory (after bootstrap) I see the
> following lines:
>
> mkdir: cannot create directory `mel': File exists
> ./configure: line 1807: ./mel/configure: No such file or directory

OK, this is the problem! But I (and most of the people here) have compiled 
Pathfinder this way for years and it always worked. It is only very recently 
(last week) that it fails. But we will bootstrap mel by hand and wait for a 
fix.

The other (autogen) problem was caused by a sick system. The line you gave me 
worked half of the time and half of the time there was no output:

Ok er is iets goed mis met mijn systeem en ik ga voor de herstart:
Zie deze log:
monetdb/MonetDB> autoconf --version | sed -n -e '/^[Aa]utoconf/{s/.* 
//g;s/-.*//g;p;q;}'
monetdb/MonetDB> autoconf --version | sed -n -e '/^[Aa]utoconf/{s/.* 
//g;s/-.*//g;p;q;}'
2.59

We rebooted and it works fine now,

JanF.




More information about the developers-list mailing list