[Monetdb-developers] IMPORTANT: imminent change to repositories

Arjen P. de Vries arjen at acm.org
Tue Jan 2 13:41:25 CET 2007


Ok, sorry about not cc-ing everything -
thought it would be better to wait till we find the issue, but let's
just assume mailing filters :-)

After checking some more of the scripts, I assumed that indeed the
previous MonetDB install may be interfering still. Eventually resorted
to

rm -rf "/ufs/arjen/local"/share/MonetDB/

This did the job.

I think (but cannot check any more unfortunately) that the old MonetDB
install had the rules.mk and MonetDB.m4 file in
"/ufs/arjen/local"/share/MonetDB/, and the new one in
"/ufs/arjen/local"/share/MonetDB/conf, and the old ones interfered (?)

Regarding:
  "no legacy lying around"
Any ideas how to achieve such state without removing *also* other
locally installed software?
I did make uninstall before updating my tree... clearly, make
uninstall is not perfect yet.

Thanks,

Arjen

On 02/01/07, Stefan Manegold <Stefan.Manegold at cwi.nl> wrote:
> Arjen,
>
> please use the mailing lists and/or bug tracker for such issue --- not only
> because I'm on "holidays" (and hence other developers *might* asnwer
> faster), but also because other users might befinet from the info.
> Thanks!
>
> On Tue, Jan 02, 2007 at 12:26:25PM +0100, Arjen P. de Vries wrote:
> > I still have the problem with clients:
> >
> > >Building clients, I get the error
> > >src/odbc/Makefile.am:13: NATIVE_WIN32 does not appear in AM_CONDITIONAL
> > >in bootstrap.
> > >
> > >I fixed it by editing this Makefile.am, and redoing the last Mbootstrap
> > >commands
> > >(automake and autoconf).
> > >
> >
> > I then with compiling get an error
> > In file included from
> > /ufs/arjen/src/MonetDB/clients/src/mapilib/Mapi.mx:655:
> > /ufs/arjen/local/include/MonetDB/common/monet_utils.h:70: error:
> > conflicting types for 'ssi
> > ze_t'
> > /usr/include/sys/types.h:110: error: previous declaration of 'ssize_t' was
> > here
>
> 1) using which compiler?
>
> 2) (again) clean build with all source up-to-date (now tags/branches!) and
>    non-modified, and no legacy lying around (in old directories and/or
>    PATHs)?
>
> 3) everything seems to work fine with nightly testing (cf.
>    http://monetdb.cwi.nl/Development/TestWeb/Current/index.html)
>
> > these monet_utils.h are from the most recent MonetDB install, and
> > clients is also up-to-date...
> >
> > is this really an error, or still installation problems?
>
> from 3), I suspect the latter...
>
> Stefan
>
> > Arjen
>
> --
> | Dr. Stefan Manegold | mailto:Stefan.Manegold at cwi.nl |
> | CWI,  P.O.Box 94079 | http://www.cwi.nl/~manegold/  |
> | 1090 GB Amsterdam   | Tel.: +31 (20) 592-4212       |
> | The Netherlands     | Fax : +31 (20) 592-4312       |
>
>


-- 
====================================================================
CWI, room C1.16          Centre for Mathematics and Computer Science
Kruislaan 413                           Email: Arjen.de.Vries at cwi.nl
1098 SJ Amsterdam                       tel:       +31-(0)20-5924306
The Netherlands                         fax:       +31-(0)20-5924312
===================== http://www.cwi.nl/~arjen/ ====================




More information about the developers-list mailing list