[Monetdb-developers] Compilation error on embeddedclient.mx

Jan Flokstra flokstra at cs.utwente.nl
Tue Jan 2 09:32:19 CET 2007


Hi All,

I tried to install the new split repository on a SuSe10 system this morning. I 
threw away all old stuff, even the prefix. The installation of buildtools and 
MonetDB went well. But I got a compilation error on the make install for the 
mapi:

Making install in tools
make[4]: Entering directory `/usr/local/flokstra/software/MonetDB4/src/tools'
make  install-am
make[5]: Entering directory `/usr/local/flokstra/software/MonetDB4/src/tools'
/bin/sh ../../libtool --tag=CC --mode=compile gcc -m64 -DHAVE_CONFIG_H -I. -I. 
-I../.. -I. -I/usr/local/flokstra/include/MonetDB 
-I/usr/local/flokstra/include/MonetDB/common 
-I/usr/local/flokstra/include/MonetDB/gdk  -I../monet -I./../monet 
-I../modules/plain -I./../modules/plain   -DLIBEMBEDDEDMIL  -g -O2 -Wall -W 
-std=c99 -Werror-implicit-function-declaration -Werror -Wno-unused-function 
-Wno-unused-label  -D_REENTRANT -c -o libembeddedmil_la-embeddedclient.lo 
`test -f 'embeddedclient.c' || echo './'`embeddedclient.c
 gcc -m64 -DHAVE_CONFIG_H -I. -I. -I../.. -I. 
-I/usr/local/flokstra/include/MonetDB 
-I/usr/local/flokstra/include/MonetDB/common 
-I/usr/local/flokstra/include/MonetDB/gdk -I../monet -I./../monet 
-I../modules/plain -I./../modules/plain -DLIBEMBEDDEDMIL -g -O2 -Wall -W 
-std=c99 -Werror-implicit-function-declaration -Werror -Wno-unused-function 
-Wno-unused-label -D_REENTRANT -c embeddedclient.c  -fPIC -DPIC 
-o .libs/libembeddedmil_la-embeddedclient.o
In file included from embeddedclient.mx:69:
embeddedclient.h:29:18: error: Mapi.h: No such file or directory
In file included from embeddedclient.mx:69:
embeddedclient.h:31: error: expected '=', ',', ';', 'asm' or '__attribute__' 
before 'embedded_mil'
embeddedclient.mx:183: error: expected '=', ',', ';', 'asm' or '__attribute__' 
before 'embedded_mil'


Any ideas,

Jan Flokstra.




More information about the developers-list mailing list