[Monetdb-developers] Clients compilaiton in windows...

Romulo Goncalves R.A.Goncalves at cwi.nl
Mon Feb 26 16:55:03 CET 2007


Sjoerd Mullender wrote:
> Romulo Goncalves wrote:
>> Compiling the clients in windows gave the error:
>>
>>          copy 
>> ".\..\..\..\..\..\src\php\Cimpl\examples\monetdb_query_demo.php" 
>> "monetdb_query_demo.php"
>>          1 file(s) copied.
>>          cl -GF -W3 -wd4273 -wd4102 -MD -nologo -Zi -Ox -I. -I.\..\..\.. 
>> "-IC:\Pthreads\include" -I.\..\..\..\..\src\php\Cimpl
>> "-I..\..\mapilib" -I.\..\..\..\..\src\php\Cimpl\..\..\mapilib 
>> -I.\..\..\..\..\..\MonetDB\NT\include -I.\..\..\..\..\..\MonetD
>> \NT\include\common -I.\..\..\..\..\..\MonetDB\NT\include\gdk 
>> -I.\..\..\..\..\..\php-5.1.4 -I.\..\..\..\..\..\php-5.1.4\main -
>> .\..\..\..\..\..\php-5.1.4\TSRM -I.\..\..\..\..\..\php-5.1.4\Zend 
>> -DPHP_WIN32 -DZEND_WIN32 -DZEND_DEBUG=0 -DZTS=1   -DLIBMONE
>> DB -DCOMPILE_DL_MONETDB -Fo"php_monetdb.obj" -c 
>> ".\..\..\..\..\src\php\Cimpl\php_monetdb.c"
>> php_monetdb.c
>> E:\Visual Studio .NET 2003\Vc7\PlatformSDK\Include\WS2tcpip.h(647) : 
>> warning C4142: benign redefinition of type
>> ..\..\..\..\src\php\Cimpl\php_monetdb.c(1721) : error C2198: 
>> 'zend_exception_get_default' : too few arguments for call throug
>>   pointer-to-function
>> ..\..\..\..\src\php\Cimpl\php_monetdb.c(1736) : error C2198: 
>> 'zend_exception_get_default' : too few arguments for call throug
>>   pointer-to-function
>> ..\..\..\..\src\php\Cimpl\php_monetdb.c(1746) : error C2198: 
>> 'zend_exception_get_default' : too few arguments for call throug
>>   pointer-to-function
>> NMAKE : fatal error U1077: 'cl' : return code '0x2'
>> Stop.
>> NMAKE : fatal error U1077: 'cd' : return code '0x2'
>> Stop.
>> NMAKE : fatal error U1077: 'cd' : return code '0x2'
>> Stop.
>> NMAKE : fatal error U1077: 'cd' : return code '0x2'
>> Stop.
>> NMAKE : fatal error U1077: '"E:\Visual Studio .NET 
>> 2003\VC7\BIN\nmake.exe"' : return code '0x2'
>> Stop.
>>
>>
>> I check my zend_exceptions and the function is defined as:
>>
>> ZEND_API zend_class_entry *zend_exception_get_default(TSRMLS_D);
>>
>> My php is php-5.1.4
> 
> That is strange.  In *my* copy of PHP-5.1.4 (both the one I already had
> and the one I just downloaded) the definition is:
> 
> + grep zend_exception_get_default php-5.1.4/Zend/zend_exceptions.h
> ZEND_API zend_class_entry *zend_exception_get_default(void);
> 
> Are you *sure* you have PHP-5.1.4?
> 
After checking the files with more careful I found out that I am using 
version 5.2.0.

Should I use 5.1.4 or should we update this function?

Regards,
Romulo
>> What values should I use? I used 0 and it compiles, but for sure it is 
>> not the best option.
>>
>>
>> Regards,
>> Romulo
>>
>> -------------------------------------------------------------------------
>> Take Surveys. Earn Cash. Influence the Future of IT
>> Join SourceForge.net's Techsay panel and you'll get the chance to share your
>> opinions on IT & business topics through brief surveys-and earn cash
>> http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
>> _______________________________________________
>> Monetdb-developers mailing list
>> Monetdb-developers at lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/monetdb-developers
> 
> 





More information about the developers-list mailing list