[Monetdb-developers] gethostbyname() problem

Jan Flokstra flokstra at cs.utwente.nl
Tue Apr 17 16:00:19 CEST 2007


On Tuesday 17 April 2007 14:48, you wrote:
> Jan,
>
> I suppose your system is Fedora Core 6, right?
> (see `grep . /etc/redhat-release /etc/fedora-release`)
>

-bash-3.1$ grep . /etc/redhat-release /etc/fedora-release
/etc/redhat-release:Fedora Core release 6 (Zod)
/etc/fedora-release:Fedora Core release 6 (Zod)
-bash-3.1$    

> What do the following do/say?
>
> 	grep localhost /etc/hosts

-bash-3.1$ grep localhost /etc/hosts
::1     localhost.localdomain   localhost

>
> 	host localhost

-bash-3.1$ host localhost
Host localhost not found: 3(NXDOMAIN)

>
> 	host <your-fully-qualified-host-name>
>
Host localhost not found: 3(NXDOMAIN)
-bash-3.1$ host u007694.hum.uva.nl
u007694.hum.uva.nl has address 146.50.78.129


> 	MapiClient -lx -h <your-fully-qualified-host-name>
>
-bash-3.1$ MapiClient -h u007694.hum.uva.nl
!ERROR mapi_reconnect: connect: Connection refused
MAPI  = monetdb at u007694.hum.uva.nl:50000
ACTION= mapi_reconnect
ERROR = Setup connection failed
-bash-3.1$                  

OK gethostbyname() now works. (It only fails now because I did not start the 
mapi listener accepting connection from other machines then localhost. How 
does this work, I use to do pfstart(true) but this now all automagically.)
So it looks as if this system is just badly configured.!

Jan.

> Stefan
>
> On Tue, Apr 17, 2007 at 02:35:06PM +0200, Jan Flokstra wrote:
> > Hi All,
> >
> > I have a very strange problem running MapiClient on a RedHat system at
> > the UVA which is not a bug I think. Problem is the gethostbyname() call
> > within Mapi is not working. The Mserver started without problems but when
> > I try to run Mapi:
> >
> > bash-3.1$ MapiClient -lx
> > MAPI  = monetdb at localhost:50000
> > ACTION= mapi_reconnect
> > ERROR = gethostbyname failed
> >
> > /proc/version says:
> > Linux version 2.6.20-1.2925.fc6 (brewbuilder at hs20-bc2-3.build.redhat.com)
> > (gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)) #1 SMP Sat Mar 10
> > 18:20:58 EST 2007
> >
> > I have had a lot of other problems with this system like bootstrap
> > complaining the filesys refcounts are not correct or the problem that
> > after installation of MonetDB all file mask bits (rwx) of group-other
> > (go) are ---,
> >
> > Anybody any idea what could cause the gethostbyname() problem here???
> >
> > JanF.
> >
> >
> > -------------------------------------------------------------------------
> > This SF.net email is sponsored by DB2 Express
> > Download DB2 Express C - the FREE version of DB2 express and take
> > control of your XML. No limits. Just data. Click to get it now.
> > http://sourceforge.net/powerbar/db2/
> > _______________________________________________
> > Monetdb-developers mailing list
> > Monetdb-developers at lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/monetdb-developers




More information about the developers-list mailing list