[Monetdb-developers] Error with MonetDB 4.12.0 for Windows

Jim Foley jfoley at jjfoley.com
Fri Sep 8 01:50:07 CEST 2006


I downloaded and installed the MonetDB 4.12.0 with SQL 2.12.0 from
SourceForge using the link on the MonetDB website.

http://prdownloads.sourceforge.net/monetdb/MonetDB-Installer-4.12.0.msi?
download

I installed it without error but when I try to start the database with
sql_server I get the following error:

C:\MonetDB>msqlserver.bat
# Monet Database Server V4.12.0
# Copyright (c) 1993-2006, CWI. All rights reserved.
# Compiled for i686-pc-win32/32bit with 32bit OIDs; dynamically linked.
# Visit http://monetdb.cwi.nl/ for further information.
!ERROR: Incompatible database version 020000, this server supports
version 030001
!mvc_init: unable to create system tables
!ERROR: interpret: no matching MIL operator to 'mapi_register(void)'.
!MAYBE YOU MEAN:
!       mapi_register(ptr) : void
MonetDB>

Laptop is a Dell C800 with 512M memory and Windows 2000 Professional,
version 5.0.2195 Service Pack 4 Build 2195.

I know this isn't the best platform to run MonetDB on but it will be a
couple of weeks before I can free up a linux server so any help would be
appreciated.

Thanks.

Jim Foley






More information about the developers-list mailing list