[Monetdb-developers] [PATCH] Loop Lifted Pathfinder sources

Fabian Groffen Fabian.Groffen at cwi.nl
Thu Nov 2 09:05:20 CET 2006


On 02-11-2006 08:40:00 +0100, Jens Teubner wrote:
> What makes our code really C99 dependent are mainly variable
> initializers in our code.  We have plenty of situations where we do

Ok, too bad my compiler didn't complain about that.

> @Fabian: What is the reason that you don't want to have the -std=c99
> flag in your next ebuild?  The compilers available for Linux provide
> excellent C99 support.  Only the ignorance of Microsoft in their
> compiler suite makes the use of C99 appear a bad thing.

Well, MonetDB at the moment is an unmaintainable beast within Gentoo
that I'm completely fed up with.  So, unless MonetDB will behave
normally, like an autotooled package should, I'll yank it from the tree
as it costs me way too much time to maintain it.  Another option for me
is to just yank XQuery support, but in that case I prefer removing
MonetDB as a whole.  Currently the MonetDB package in Gentoo is hard
masked -- and you know what that means.

You can see the initial patch as a signal that I want to help out doing
the dirty work.  If, however, you don't feel like investing in it,
neither will I.




More information about the developers-list mailing list