[Monetdb-developers] Get xquery timing, Error when running examples, etc

Jens Teubner jens.teubner at in.tum.de
Thu Jul 6 12:01:06 CEST 2006


On Thu, Jul 06, 2006 at 05:29:31PM +0800, kla gw wrote:

Hi Klarinda,

thanks for your interest in MonetDB/XQuery.  Though I am only used to
the Unix version of MonetDB/XQuery, I will try to give my best to answer
your request.

> 1. How to run the query from the command prompt and get the timing?
> Currently, everytime I want to run the query, I have to start XQuery
> Server (start - all programs - monetdb xquery - XQuery Server). After
> that I save the xquery into .xq file, then run it by right click -
> open with MPFClient. I've tried the following in XQuery Server but it
> gives me error:
> 
> MonetDB>MapiClient -T -lx test.xq;
> !ERROR: "MapiClient -T -lx test.xq;"
> !                                  ^
> ! can't help you here, sorry.
> MonetDB>

Issue this command from the Windows command line, *not* from within the
MonetDB server.  You may have to call MapiClient with a fully qualified
path (`C:\some\long\path\MapiClient').

> 2. I tried to run the example in the website, books1.xq and books2.xq
> and slashdot.xq. In the files, the xml file is from internet. But when
> I run the files, the following error message come out:
> 
> ERROR: No such file or directoryI/O warning : failed to load external entity
> "http://monetdb.cwi.nl/XQuery/files/bib.xml"
> ERROR: shred:mainSHREDDER: xmlCreateURLParserCtxt("
> http://monetdb.cwi.nl/XQuery/files/bib.xml") failed
> ERROR: CMDshred2bats: operation failed.
> ERROR: interpret_params: +(param 2): evaluation error.
> 
> Is it connection problem? How to modify the connection settings so that I
> can download data from internet?

(This may be OS dependent, so no guarantees for my answer.)

This looks to me like a connection problem.  What you could do is
download the respective XML files to your harddisk, then replace the URL
strings in the query files with `file:// ...'.

Actually, we're relying here on the HTTP implementation of a third-party
library (the libxml2 library, http://www.xmlsoft.org/).  Unfortunately,
I don't know the details on how this library tries to access the
network and what you have to do to get network access running.

> 3. voc2.xq and voc5.xq give the following error:
> 
> type error: [err:XPTY0004] Orderspec requires at most one atomic item
> (given: string*).

Apparently we have an erroneous example on the net, sorry about that.
We'll fix that soon.  The error message is actually correct, the query
is wrong.

> 4. Where is the shredded document being stored? Is it in the place
> where I install the program or in My Documents? Because before I
> uninstall 0.10.2, I shredded some documents, and after I uninstall
> then install 0.12.0, the shredded xml documents are still there.

(again OS specific)

I think the database is held in the installation directory of MonetDB.
Look out for a directory that is called `dbfarm'.  The structure below
it contains the MonetDB database.

Just let us know if you experience any more problems.

Jens

-- 
Jens Teubner
Technische Universitaet Muenchen, Department of Informatics
D-85748 Garching, Germany
Tel: +49 89 289-17259     Fax: +49 89 289-17263

I invented <Ctrl><Alt><Delete>, but Bill Gates made it famous.
                 -- David Bradley, member of the original IBM PC design team




More information about the developers-list mailing list