[Monetdb-developers] Get xquery timing, Error when running examples, etc

Sjoerd Mullender sjoerd at acm.org
Thu Jul 6 12:34:37 CEST 2006


On 2006-07-06 11:29, kla gw wrote:
> Hi,
>  
> I just started to use MonetDB. My PC is Windows XP. I installed the
> MonetDB-XQuery-0.10.2.msi and few weeks later after the newer version
> come out, I uninstalled from Control Panel & install 0.12.0.
>  
>  
> I have several questions:
>  
> 1. How to run the query from the command prompt and get the
> timing? Currently, everytime I want to run the query, I have to start
> XQuery Server (start - all programs - monetdb xquery - XQuery Server).
> After that I save the xquery into .xq file, then run it by right click -
> open with MPFClient. I've tried the following in XQuery Server but it
> gives me error:
>  
> MonetDB>MapiClient -T -lx test.xq;
> !ERROR: "MapiClient -T -lx test.xq;"
> !                                  ^
> ! can't help you here, sorry.
> MonetDB>

Take a look at the BAT script MPFclient.bat in the installation folder
(normally C:\Program Files\CWI\MonetDB-XQuery).  Towards the end there
is a call to MapiClient.exe.  You can add a -T option there, however
that would mess up the XML file that is generated and given to Internet
Explorer.  So a better solution might be to copy the script (but leave
it in the same folder) and modify it to save the output of the
MapiClient.exe command into a file which you should not open (the bit
starting with the && on the MapiClient line) or throw away like is done
in the script.

> 2. I tried to run the example in the website, books1.xq and books2.xq
> and slashdot.xq. In the files, the xml file is from internet. But when I
> run the files, the following error message come out:
>  
> ERROR: No such file or directoryI/O warning : failed to load external
> entity "http://monetdb.cwi.nl/XQuery/files/bib.xml"
> ERROR: shred:mainSHREDDER: xmlCreateURLParserCtxt("
> http://monetdb.cwi.nl/XQuery/files/bib.xml") failed
> ERROR: CMDshred2bats: operation failed.
> ERROR: interpret_params: +(param 2): evaluation error.
>  
> Is it connection problem? How to modify the connection settings so that
> I can download data from internet?

Try loading the xml file in your web browser.  If that doesn't succeed
either, it's a connection problem.

> 3. voc2.xq and voc5.xq give the following error:
>  
> type error: [err:XPTY0004] Orderspec requires at most one atomic item
> (given: string*).

I don't know what the issue is here.  Somebody else should comment.

> 4. Where is the shredded document being stored? Is it in the place where
> I install the program or in My Documents? Because before I uninstall
> 0.10.2, I shredded some documents, and after I uninstall then install
> 0.12.0 , the shredded xml documents are still there.

The database is stored in %APPDATA%\MonetDB (normally C:\Documents and
Settings\<user name>\Application Data\MonetDB) and is not removed on
uninstall.  See the Mserver.bat script.

-- 
Sjoerd Mullender

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 370 bytes
Desc: OpenPGP digital signature
URL: <http://www.monetdb.org/pipermail/developers-list/attachments/20060706/7c9a0e2b/attachment.sig>


More information about the developers-list mailing list