[Monetdb-developers] [Monetdb-checkins] MonetDB/conf conf.bash, 1.129, 1.130

Jens Teubner jens.teubner at in.tum.de
Wed Jul 5 10:13:15 CEST 2006


On Wed, Jul 05, 2006 at 07:34:03AM +0000, Stefan Manegold wrote:

> [...]
>
> Debian's default flex 2.5.31 does not like the Pathfinder code;
> hence, we use our own flex 2.5.33 instead.
>
> [...]

I haven't realized that we have a problem there, but your commit message
seems suspicious to me:

Your checkin only modifies conf.bash.  That means, only development
folks will be affected by your checkin.  Users will not have your
specialized flex version installed.

If we indeed have problems with flex 2.5.31, I guess we'll either have
to either

 (a) change our code such that it does compile with 2.5.31.  I don't
     know what the problem was on Debian, so I have no clue if we could
     fix this.

Or

 (b) we should check the flex version in ./configure and abort
     compilation in case the installed flex version is not sufficient to
     compile Pathfinder.

Maybe you can enlighten me (maybe also others) what the actual flex
problem was.  I cannot find anything in the TestWeb.

Jens

-- 
Jens Teubner
Technische Universitaet Muenchen, Department of Informatics
D-85748 Garching, Germany
Tel: +49 89 289-17259     Fax: +49 89 289-17263

This email was written with 100% recycled electrons.




More information about the developers-list mailing list