[Monetdb-developers] bootstrap problems

Fabian Groffen Fabian.Groffen at cwi.nl
Wed Dec 27 11:30:14 CET 2006


Hi,

On 27-12-2006 10:52:37 +0100, Manuel Mayr wrote:
> Hi all,
> yesterday I updated buildtools, MonetDB and I checked out the MonetDB4 
> module. buildtools and MonetDB working fine after i updated autoconf and 
> automake to the newest versions but with MonetDB4 i get the errors 
> described in the attachment.

Be aware of the changes that were made to the source repos, as Martin
already said, but...

Content-Description: bootstrap output
> using /usr/bin/glibtool and /usr/bin/glibtoolize.
> automake 1.10 is 1.7 or newer. Good.
> autoconf 2.61 is 2.57 or newer. Good.

> Putting files in AC_CONFIG_AUX_DIR, `conf'.
> /opt/local/share/aclocal/libmcrypt.m4:17: warning: underquoted definition of AM_PATH_LIBMCRYPT
> /opt/local/share/aclocal/libmcrypt.m4:17:   run info '(automake)Extending aclocal'

This looks like your installation is either b0rk3ned, or MacPorts
(???  wild guess) installs a wrapper for aclocal that automagically
switches down to an older version.

I didn't have much luck myself with the bootstrap script, too (it does
too much magic for me) so I ended up doing the autoconf stuff myself
with the same versions you have, which works out fine for me now.





More information about the developers-list mailing list