[Monetdb-developers] Re: Bugreport MonetDB

Fabian Fabian.Groffen at cwi.nl
Mon Oct 10 18:48:27 CEST 2005


try a `ps ax | grep Mserver` to see if there is any (zombie) process 
around that still keeps the lock.

Can you define a bit more clear what you mean with 'errors occurred. 
The connection was lost with the (local) monetDB'?

Thanks in advance.


Nicolaas Heyning wrote:
> Dear mr/mrs,
> 
> We are experimenting with MonetDB to create a google-like search engine 
> with a database of some 300.000 urls.
> We used the COPY INTO TEST FROM /../urlFile.txt statement to load all 
> the data in a table. This worked fine and very fast.
> After this we tried to run the same script again, but errors occured. 
> The connection was lost with the (local) monetDB and when we tried to 
> regain it through:
> /home/mjmetter/MonetDB/bin/Mserver --dbinit "module(sql_server); 
> sql_server_start();"
> we got the following output:
> !FATAL: GDKlockHome: Database lock '.gdk_lock' denied.
> 
> We think that the loss of connection is caused by the amount of data 
> that was inserted into the table. We did not manage to solve this 
> problem, so maybe you can help us.
> 
> Thanks in advance,
> Michael Metternich
> Nicolaas Heyning




More information about the developers-list mailing list