[Monetdb-developers] new requirements for building MonetDB and associated projects

Marcin Zukowski Marcin.Zukowski at cwi.nl
Wed Aug 24 11:50:56 CEST 2005


> For example, after running:
>   python setup.py install --prefix=$MONETDB_PREFIX
> you should somewhere do:
>   export PYTHONPATH=$PYTHONPATH:$MONETDB_PREFIX/lib/autogen
Apparently, I was too fast, it should rather be something like:
   export PYTHONPATH=$PYTHONPATH/lib/python2.4/site-packages/
helped for me.
marcin

> 
> cheers,
> marcin
> 
> Sjoerd Mullender wrote:
> 
>> There is a new (well already quite a few weeks old) CVS module available
>> at our SourceForge repository called buildtools.  This module is now a
>> prerequisite for compiling MonetDB and all other projects.
>>
>> Check out buildtools:
>>     export CVSROOT=...
>>     cvs checkout buildtools
>>     cd buildtools
>>     # read REAME file and follow instructions
>>
>> Then you can update your MonetDB and other projects and bootstrap and
>> build those projects.  The main difference is:
>> - autogen.py must be found in your $PATH (autogen is now part of
>> buildtools);
>>
>> - Mx must either be found in your $PATH, or you must specify the option
>> --with-mx=.../Mx on the configure command line;
>>
>> - mel must either be found in your $PATH, or you must specify the option
>> --with-mel=.../mel on the configure command line;
>>
>> - for Pathfinder, burg must either be found in your $PATH, or you must
>> specify --with-burg=.../burg on the configure command line.
>>
> 

-- 
: Marcin Zukowski < marcin at cwi.nl || eru at mimuw.edu.pl >
: All true wisdom is found in signatures




More information about the developers-list mailing list