Bug 6983 - monetdb allows to use non-existing optimizer pipe
Summary: monetdb allows to use non-existing optimizer pipe
Status: RESOLVED FIXED
Alias: None
Product: SQL
Classification: Unclassified
Component: all (show other bugs)
Version: -- development
Hardware: x86_64 (amd64/em64t) Linux
: Normal normal
Assignee: SQL devs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-06 16:46 CEST by Roberto Cornacchia
Modified: 2020-11-24 11:37 CET (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Cornacchia 2020-10-06 16:46:32 CEST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36
Build Identifier: 

monetdb create test
monetdb release test
monetdb set optpipe=whatever test
mclient -d test


Welcome to mclient, the MonetDB/SQL interactive terminal (unreleased)
Database: MonetDB v11.39.0 (hg id: be68ac80bf), 'mapi:monetdb://photon.hq.spinque.com:56000/test'
FOLLOW US on https://twitter.com/MonetDB or https://github.com/MonetDB/MonetDB
Type \q to quit, \? for a list of available commands
auto commit mode: on
sql>select * from sys.tables;
Function 'calc.+' not defined



Related to the optimizer pipe, a question: is the following intentional in Oct2020?

sql>set optimizer='default_pipe';
SET: Variable 'optimizer' unknown

If so, is there a new way to set the optimizer pipe from a client session?

Reproducible: Always
Comment 1 Pedro Ferreira 2020-10-06 17:12:09 CEST
Hello Roberto,

For the last example, can you tell which schema are you on? Due to scoping changes, the parser will attempt to find the variable on the current session's schema.
Comment 2 Roberto Cornacchia 2020-10-06 17:22:04 CEST
Ah I see. I was indeed in a user-created schema.

This works:

sql>set sys.optimizer='default_pipe';
operation successful
Comment 3 Pedro Ferreira 2020-10-06 17:32:01 CEST
It's on our TODO list to add a schema search path for SQL objects. It will solve the problem to bind a sys schema function at another schema, as well as session variables.

About the validation of the MAL pipeline, it's something we have to see as well.
Comment 4 MonetDB Mercurial Repository cwiconfidential 2020-10-28 16:59:16 CET
Changeset 4d973ec7aa13, made by Pedro Ferreira <pedro.ferreira@monetdbsolutions.com> in the MonetDB repo, refers to this bug.

For complete details, see https://dev.monetdb.org/hg/MonetDB?cmd=changeset;node=4d973ec7aa13

Changeset description:

	Fix for bug 6983, test if the sql optimizer pipeline is valid when the SQL scenario is launched
Comment 5 MonetDB Mercurial Repository cwiconfidential 2020-10-30 15:26:13 CET
Changeset ee92764fedeb, made by Pedro Ferreira <pedro.ferreira@monetdbsolutions.com> in the MonetDB repo, refers to this bug.

For complete details, see https://dev.monetdb.org/hg/MonetDB?cmd=changeset;node=ee92764fedeb

Changeset description:

	Added test and expected result for bug 6983