Bug 2854 - Complete column name denotations
Summary: Complete column name denotations
Status: RESOLVED DUPLICATE of bug 2526
Alias: None
Product: SQL
Classification: Unclassified
Component: all (show other bugs)
Version: 11.7.7 (Dec2011-SP1) [obsolete]
Hardware: Other Linux
: Normal normal
Assignee: SQL devs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 12:45 CEST by Martin Kersten
Modified: 2012-03-15 18:17 CET (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kersten cwiconfidential 2011-08-12 12:45:33 CEST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110621 Fedora/3.6.18-1.fc14 Firefox/3.6.18
Build Identifier: 

sql>    set avgtemp = 
more>        (select average(value)
more>        from datacell.temperature , datacell.alarms
more>        where datacell.temperature.tag > now() - interval '2' minute
more>        and datacell.temperature.area = datacell.alarms.area );
TODO: column names of level >= 3


Reproducible: Always
Comment 1 Stefan Manegold cwiconfidential 2011-08-12 13:20:03 CEST
(temporary) work-around: use aliases:

set avgtemp =
     (select average(value)
     from datacell.temperature as dc_temp, datacell.alarms as dc_alarms
     where dc_temp.tag > now() - interval '2' minute
     and dc_temp.area = dc_alarms.area );
Comment 2 Stefan Manegold cwiconfidential 2011-08-12 13:21:30 CEST
simplified test:

sql>select count(sys.tables.name) from sys.tables;
TODO: column names of level >= 3

sql>select count(st.name) from sys.tables as st;
+------+
| L4   |
+======+
|   33 |
+------+
1 tuple (2.834ms)
Comment 3 Sjoerd Mullender cwiconfidential 2012-03-15 18:17:21 CET

*** This bug has been marked as a duplicate of bug 2526 ***